View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006779ParaView(No Category)public2008-04-09 17:252011-01-13 17:00
ReporterKen Moreland 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.4Fixed in Version3.4 
Summary0006779: Cannot save Exodus as anything
DescriptionOpen an exodus file (like disk_out_ref or can). Then try to save the data. ParaView gives no choice for the file type and raises an error if you try to select a file to save to.
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0006885closedNathan Fabian Multiblock Exodus writer 
related to 0006698closedUtkarsh Ayachit Multi-block writer does not work in parallel 
related to 0006780closedBerk Geveci Cannot extract blocks from exodus file 

-  Notes
(0012216)
Utkarsh Ayachit (administrator)
2008-06-03 11:04

It can be saved as vtm. There's another bug for fixing the exodus writer to write multiblock datasets.
(0012244)
Alan Scott (manager)
2008-06-04 16:21

vtm doesn't work. Try the following:
Client/server, 6 servers.
Open up disk_out_ref.exo. All variables on. Apply.
Save as junk.vtm.
Edit/Delete all.
File/ Open/ junk.vtm. Apply.

Output is as follows:
ERROR: In C:\alan\paraviewNightlyTrunk\src\ParaView3\VTK\IO\vtkDataReader.cxx, line 763
vtkPolyDataReader (0A527038): Unsupported cell attribute type: ² for file: (Null FileName)

Should we keep this bug open, or close it and open another for vtm files?
(0012245)
Alan Scott (manager)
2008-06-04 16:23

One more note, after the bug listed above, you cannot color junk.vtm by anything.
(0012858)
Utkarsh Ayachit (administrator)
2008-07-29 13:02

Fixing the vtm reading problem.

/cvsroot/ParaView3/ParaView3/VTK/IO/vtkXMLReader.cxx,v <-- VTK/IO/vtkXMLReader.cxx
new revision: 1.53; previous revision: 1.52
(0012865)
Alan Scott (manager)
2008-07-29 14:09

We need a vtm fix.
(0012866)
Alan Scott (manager)
2008-07-29 14:10

Woops, I didn't see that Utkarsh had already fixed it.
(0012962)
Alan Scott (manager)
2008-08-07 16:14

This is giving me troubles still, using can.exo.

client/server, but I suspect that doesn't matter.
Open can.exo. All variables on (but shouldn't matter)
Save as junk.vtm.
Delete all
Open junk.vtm. Output is as listed below, Unsupported cell attribute type:

give me a call if you think I am in error.
(0013077)
Utkarsh Ayachit (administrator)
2008-08-19 15:20

The issue is due to the fact that vtm writers cannot write in parallel correctly. BUG 0006698 captures that issue, hence I am making this resolved (since the original bug is indeed resolved).
(0013080)
Alan Scott (manager)
2008-08-19 15:28

The issue i was having is that the vtm writer is not parallel. It works serial. Closed.

- Issue History
Date Modified Username Field Change
2008-04-09 17:25 Ken Moreland New Issue
2008-04-09 17:25 Ken Moreland Status backlog => tabled
2008-04-09 17:25 Ken Moreland Assigned To => Berk Geveci
2008-04-09 17:27 Ken Moreland Relationship added related to 0006780
2008-06-03 11:04 Utkarsh Ayachit Status tabled => @80@
2008-06-03 11:04 Utkarsh Ayachit Resolution open => no change required
2008-06-03 11:04 Utkarsh Ayachit Note Added: 0012216
2008-06-04 16:21 Alan Scott Status @80@ => @20@
2008-06-04 16:21 Alan Scott Resolution no change required => reopened
2008-06-04 16:21 Alan Scott Note Added: 0012244
2008-06-04 16:23 Alan Scott Note Added: 0012245
2008-07-09 10:48 Utkarsh Ayachit Status @20@ => tabled
2008-07-09 10:48 Utkarsh Ayachit Assigned To Berk Geveci => Utkarsh Ayachit
2008-07-24 13:57 Utkarsh Ayachit Relationship added duplicate of 0006885
2008-07-24 13:57 Utkarsh Ayachit Duplicate ID 0 => 6885
2008-07-24 13:57 Utkarsh Ayachit Status tabled => @80@
2008-07-24 13:57 Utkarsh Ayachit Resolution reopened => duplicate
2008-07-29 13:02 Utkarsh Ayachit Status @80@ => @20@
2008-07-29 13:02 Utkarsh Ayachit Resolution duplicate => reopened
2008-07-29 13:02 Utkarsh Ayachit Status @20@ => @80@
2008-07-29 13:02 Utkarsh Ayachit Resolution reopened => fixed
2008-07-29 13:02 Utkarsh Ayachit Note Added: 0012858
2008-07-29 13:02 Utkarsh Ayachit Duplicate ID 6885 => 0
2008-07-29 14:09 Alan Scott Status @80@ => @20@
2008-07-29 14:09 Alan Scott Resolution fixed => reopened
2008-07-29 14:09 Alan Scott Note Added: 0012865
2008-07-29 14:10 Alan Scott Status @20@ => @80@
2008-07-29 14:10 Alan Scott Resolution reopened => fixed
2008-07-29 14:10 Alan Scott Note Added: 0012866
2008-08-07 16:14 Alan Scott Status @80@ => @20@
2008-08-07 16:14 Alan Scott Resolution fixed => reopened
2008-08-07 16:14 Alan Scott Note Added: 0012962
2008-08-19 15:18 Utkarsh Ayachit Relationship added related to 0006698
2008-08-19 15:20 Utkarsh Ayachit Status @20@ => @80@
2008-08-19 15:20 Utkarsh Ayachit Resolution reopened => fixed
2008-08-19 15:20 Utkarsh Ayachit Note Added: 0013077
2008-08-19 15:28 Alan Scott Status @80@ => closed
2008-08-19 15:28 Alan Scott Note Added: 0013080
2009-05-13 13:58 Utkarsh Ayachit Target Version => 3.4
2009-05-13 13:59 Utkarsh Ayachit Fixed in Version => 3.4
2011-01-13 17:00 Source_changeset_attached => VTK master a2bd8391
2011-01-13 17:00 Source_changeset_attached => VTK master 020ef709
2011-06-16 13:10 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker