View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005432ParaView(No Category)public2007-07-30 15:302007-08-14 09:38
ReporterClinton Stimpson 
Assigned ToClinton Stimpson 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005432: wrong keyframe created after creating camera keyframe
Descriptionstart up paraview.
create a camera keyframe
delete the two keyframes
create a sphere
create a keyframe to animation the center(0) of the sphere.
It created a camera key frame to animate that.
You get the error
"vtkSMCameraManipulatorProxy (0x14ebdc0): Too few keyframes to animate."

ParaView 3.0 has this problem too.
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0008347)
Clinton Stimpson (developer)
2007-08-06 19:34

/cvsroot/ParaView3/ParaView3/Qt/Components/pqAnimationPanel.cxx,v <-- pqAnimationPanel.cxx
new revision: 1.42; previous revision: 1.41

Clean up cues after the last keyframe is removed.
The old camera manipulator was still around, which gave those errors.
(0008350)
Ken Moreland (manager)
2007-08-07 11:36

I just tried this on today's build, and I got the same error.
(0008359)
Clinton Stimpson (developer)
2007-08-07 12:24

You were able to reproduce it because I forgot to commit these files.

pqAnimationScene.cxx 1.17
pqAnimationScene.h 1.11

- Issue History
Date Modified Username Field Change
2007-08-06 19:33 Clinton Stimpson Assigned To Berk Geveci => Clinton Stimpson
2007-08-06 19:34 Clinton Stimpson Status tabled => @80@
2007-08-06 19:34 Clinton Stimpson Resolution open => fixed
2007-08-06 19:34 Clinton Stimpson Note Added: 0008347
2007-08-07 11:36 Ken Moreland Status @80@ => @20@
2007-08-07 11:36 Ken Moreland Resolution fixed => reopened
2007-08-07 11:36 Ken Moreland Note Added: 0008350
2007-08-07 12:24 Clinton Stimpson Status @20@ => @80@
2007-08-07 12:24 Clinton Stimpson Resolution reopened => fixed
2007-08-07 12:24 Clinton Stimpson Note Added: 0008359
2007-08-14 09:38 Ken Moreland Status @80@ => closed
2011-06-16 13:10 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker