View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013160VTK(No Category)public2012-05-10 10:482013-04-05 20:34
ReporterJensH 
Assigned ToUtkarsh Ayachit 
PriorityhighSeverityminorReproducibilityhave not tried
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version5.8.0 
Target VersionFixed in Version 
Summary0013160: vtkSTLReader does not read files any more
DescriptionI have a piece of code, that uses the vtkSTLReader to perform some manipulations on a STL file via python and on the older VTK versions it works great. But after the update via git (d1db5b1), vtk raises the following error on reading an STL.

<snip>
vtkSTLReader (0x7ffc819363c0): STLReader error reading file: /Users/jens/test.stl Premature EOF while reading end solid.
</snip>

The stl can be displayed in paraview and was not altered at all, during the last year. My guess is, that this was introduced in release bbc7a0ef.

If you need further information, please let me know.

Jens
TagsNo tags attached.
ProjectRelease
Typeincorrect functionality
Attached Filestgz file icon stl.tgz [^] (2,095,200 bytes) 2012-05-11 03:33
? file icon box.stl [^] (1,518 bytes) 2012-05-11 05:07

- Relationships Relation Graph ] Dependency Graph ]
related to 0013101closedUtkarsh Ayachit ParaView STL reader broken 

-  Notes
(0028584)
Utkarsh Ayachit (administrator)
2012-05-10 10:54

Can you post a sample dataset please?
(0028585)
Bill Lorensen (developer)
2012-05-10 12:04

Jens,

We added more error checking to the STL reader. Is this a file that you created?
(0028588)
JensH (reporter)
2012-05-11 03:41
edited on: 2012-05-11 04:18

First of all, thanks for your almost instant reply!

@Utkarsh: I've uploaded the geometry as a tar.gz, otherwise it would be to large

@Bill: This is an STL I received from a workshop's site and it is in the ASCII format, not binary. I've used exactly that (and some other) stl file to run the code and it worked like a charm.

(0028590)
JensH (reporter)
2012-05-11 05:06

I've created a box in paraview exported it as a STL after triangulating it. Using the ReadASCIISTL method results in the same error message. This stl is attatched as well to this report.
(0028591)
JensH (reporter)
2012-05-11 07:17

Ok, I've changed the branch from release to master and now seems to be working.
(0028619)
Utkarsh Ayachit (administrator)
2012-05-17 12:59

This has been fixed.


commit 1d6745888bcc34b260410a3cdbba49ecf0084ba2
Author: Utkarsh Ayachit <utkarsh.ayachit@kitware.com>
Date: Tue Apr 17 14:54:05 2012 -0400

    BUG 0013101. STL ascii reader was report failures prematurely.
    
    STL ascii reader was reporting error when eof was reached at an expected
    location. This was causing the reader to fail for the STL file attached with the
    bug report.
    
    Change-Id: I734d2c8d8c85854df3d2a63bae6ba23bccf7a9c2

- Issue History
Date Modified Username Field Change
2012-05-10 10:48 JensH New Issue
2012-05-10 10:54 Utkarsh Ayachit Note Added: 0028584
2012-05-10 12:04 Bill Lorensen Note Added: 0028585
2012-05-11 03:33 JensH File Added: stl.tgz
2012-05-11 03:41 JensH Note Added: 0028588
2012-05-11 03:48 JensH Note Added: 0028589
2012-05-11 04:18 JensH Note Deleted: 0028589
2012-05-11 04:18 JensH Note Edited: 0028588 View Revisions
2012-05-11 05:06 JensH Note Added: 0028590
2012-05-11 05:07 JensH File Added: box.stl
2012-05-11 07:17 JensH Note Added: 0028591
2012-05-17 12:56 Utkarsh Ayachit Assigned To => Utkarsh Ayachit
2012-05-17 12:56 Utkarsh Ayachit Status backlog => tabled
2012-05-17 12:56 Utkarsh Ayachit Resolution open => fixed
2012-05-17 12:59 Utkarsh Ayachit Note Added: 0028619
2012-05-17 12:59 Utkarsh Ayachit Status tabled => customer review
2012-05-17 12:59 Utkarsh Ayachit Resolution fixed => duplicate
2012-05-30 11:09 Utkarsh Ayachit Relationship added related to 0013101
2013-04-05 20:34 Berk Geveci Status customer review => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker