[Paraview] How to color by Cell Data

Michael Jackson mike.jackson at bluequartz.net
Wed Mar 3 14:11:18 EST 2010

Drum roll please....... "Corrupt" set of paraview preferences. After  
installing 10.5.8 clean from my installation disks everything worked  
as it was supposed to. So that means the only difference is between  
the 2 user environments. Preferences is the first to check. Looked in  
my home directory, blew away the .config directory, launched paraview  
on the "trouble" machine and now everything works. I could completely  
replicate this issue simply by swapping in and out the "good" and  
"bad" preferences for ParaView. I have the "bad" preferences if anyone  
wants them to try and debug what was going on.

Thanks to EVERYONE who helped me with ideas.

Mike Jackson                  mike.jackson at bluequartz.net

On Mar 3, 2010, at 12:39 PM, Eric E. Monson wrote:

> I just tried the 3.6.2 binary on a MacBook booted off an old 10.5.7  
> usb drive backup and all of the Color By entries showed up just  
> fine. The MacBook has the GMA 950 on-board graphics chipset. The Mac  
> Pro I used before has the NVidia GeForce 8800 GT card. If you can  
> think of any other specs that might be crucial, just drop me a line.
> -Eric
> On Mar 3, 2010, at 12:18 PM, Michael Jackson wrote:
>> I just fire up the 3.6.2 binary from Kitware on OS X 10.5.8 on a  
>> MacBook Pro with nVidea 8600M graphics card and the information tab  
>> is identical to your image BUT my "Color By" drop down only shows  
>> "Solid Color", "Ids", "Normals", all of which are "Point Data" and  
>> NOT "Cell Data".
>> So not really sure what is up. If someone wants to remotely work on  
>> my machine email me off list and I'll get you setup.
>> Mike Jackson.
>> On 3/3/2010 12:06 PM, Eric E. Monson wrote:
>>> I don't have a CVS build on OS X 10.5.8 any more, but I booted  
>>> into it and ran the 3.6.2 binary and SphereSource->GenerateIds  
>>> shows all four arrays in Color By and three in Information.
>>> -Eric
>>> On Mar 3, 2010, at 10:30 AM, Jérôme wrote:
>>>> By my side, yes: SphereSource -> GenerateIds. You are right:  
>>>> Information
>>>> tab shows the celldata and pointdata array, whereas "Color by"  
>>>> has only point.
>>>> Jerome
>>>> 2010/3/3 Utkarsh Ayachit <utkarsh.ayachit at kitware.com <mailto:utkarsh.ayachit at kitware.com 
>>>> >>
>>>>   Mmm..not sure if that'd help, since you said you can reproduce  
>>>> the
>>>>   issue with GenerateIds filter as well, right?
>>>>   Utkarsh
>>>>   On Wed, Mar 3, 2010 at 9:51 AM, Michael Jackson
>>>>   <mike.jackson at bluequartz.net
>>>>   <mailto:mike.jackson at bluequartz.net>> wrote:
>>>>> Do you want my data file?
>>>>> Mike J.
>>>>> On 3/3/2010 9:28 AM, Utkarsh Ayachit wrote:
>>>>>> Mike, but the cell data shows up correctly on the information  
>>>>>> tab,
>>>>>> right? So the cell data is being loaded, and even reported to
>>>>>> ParaView. It's hard to imagine why it would be doing what it's
>>>>   doing,
>>>>>> esp. with the precompiled binaries on Mac, since they work
>>>>   fine for
>>>>>> me, on my Mac 10.6  :).
>>>>>> It cannot be a mere GUI issue since from the debugging report  
>>>>>> that
>>>>>> Mike gave us before, ParaView indeed doesn't report those cell
>>>>   arrays
>>>>>> to the client when rendering. I just wish I could reproduce it
>>>>   somehow
>>>>>> somewhere so I could debug it  :). I am going to test on Os X
>>>>   10.5 to
>>>>>> see if we have any better luck.
>>>>>> Utkarsh
>> _______________________________________________
>> Powered by www.kitware.com
>> Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html
>> Please keep messages on-topic and check the ParaView Wiki at: http://paraview.org/Wiki/ParaView
>> Follow this link to subscribe/unsubscribe:
>> http://www.paraview.org/mailman/listinfo/paraview

More information about the ParaView mailing list