Difference between revisions of "Salinas August 2009"

From KitwarePublic
Jump to: navigation, search
(How to start ParaView)
 
(11 intermediate revisions by the same user not shown)
Line 31: Line 31:
 
** Note that you have to select the '''Apply''' button whenever it has turned '''green'''.  Whenever you turn on '''Mode Shapes''', or change '''Mode''', you will have to select the '''Apply''' button.
 
** Note that you have to select the '''Apply''' button whenever it has turned '''green'''.  Whenever you turn on '''Mode Shapes''', or change '''Mode''', you will have to select the '''Apply''' button.
 
** Also notice that ParaView Mode Shapes are '''0''' based.  Thus, take any Mode that you want to see and subtract 1.  (I hope that this will change to be 1 based in the near future.)
 
** Also notice that ParaView Mode Shapes are '''0''' based.  Thus, take any Mode that you want to see and subtract 1.  (I hope that this will change to be 1 based in the near future.)
** '''Animate'''.  Try setting Mode to 2, then 3, then 4, and animate.  (Don't forget that ParaView input is 0 based!)
+
** '''Animate'''.  This is the right pointing green triangles in the middle of the toolbars at the top of the screen that has the label Play.  Try setting Mode to 2, then 3, then 4, and animate.  (Don't forget that ParaView input is 0 based!)
  
 
* Spreadsheet
 
* Spreadsheet
 
** Select the '''Split vertical''' icon (located in the upper right corner of the 3d viewport).
 
** Select the '''Split vertical''' icon (located in the upper right corner of the 3d viewport).
 
** '''Spreadsheet view'''.
 
** '''Spreadsheet view'''.
** Make sure the '''eyeball''' is turned on.
+
** Make sure the '''eyeball''' next to the part name in the Pipeline Browser is turned on.
 
** Change Attribute to '''Field Data'''.
 
** Change Attribute to '''Field Data'''.
  
Line 48: Line 48:
 
** Choose the '''second''' dataset.   
 
** Choose the '''second''' dataset.   
 
** '''Filters/ Common/ Glyph filter'''.  '''Apply'''.
 
** '''Filters/ Common/ Glyph filter'''.  '''Apply'''.
** The Scale Factor is too small.  Click '''Edit''', and change the '''Scale Factor''' to '''0.5'''.  '''Apply'''.
+
** The Scale Factor is too small.  On the Properties tab, click '''Edit''', and change the '''Scale Factor''' to '''0.5'''.  '''Apply'''.
 
** '''Reset''' Icon (below and right of the counterclockwise red arrow)
 
** '''Reset''' Icon (below and right of the counterclockwise red arrow)
 
** '''Animate'''.
 
** '''Animate'''.
  
 
=Animate Time=
 
=Animate Time=
** Edit/ Delete All.
+
** Edit/ '''Delete All'''.
** Open sub-trans.exo.  Turn on all variables, Apply.
+
** '''Open''' sub-trans.exo.  Turn on all variables, '''Apply'''.
** Change '''Solid Color''' to '''disp'''
+
** Lets color by displacement.  Change '''Solid Color''' to '''disp''', in the pulldown box below the Sources menu.
** Sources/ Annotate Time.
+
** Sources/ '''Annotate Time'''.
** Animate.
+
** '''Animate'''.
 
** You should see no change.  There are two reasons:
 
** You should see no change.  There are two reasons:
*** The displacement is too small.  Go back to time step 0.  On the Properties tab, change Apply Displacements to 50 magnitude.  Animate.
+
*** The displacement is too small.  Go back to time step 0.  On the Properties tab, change Apply Displacements to '''50''' magnitude.  '''Animate'''.
*** The displacement min and max are not set correctly.  The quickest way to fix this is to the last time step, and hit the Rescale to Data Range icon (below the View menu).  Next, hit the Color Legend icon.  Now, go back to time step 0, and animate.
+
*** The displacement min and max are not set correctly.  The quickest way to fix this is to go to the last time step, and hit the '''Rescale to Data Range''' icon (below the View menu).  Next, hit the '''Color Legend''' icon (below the File menu).  Now, go back to time step 0, and '''animate'''.
 
** Try coloring by aForce.  Notice that time step 0 has the correct data, NOT the last time step.
 
** Try coloring by aForce.  Notice that time step 0 has the correct data, NOT the last time step.
  
 
* Save screenshot and save movie
 
* Save screenshot and save movie
** File/ Save Screenshot
+
** File/ '''Save Screenshot'''.
** File/ Save Animation
+
** File/ '''Save Animation'''.
  
 
=Plot Variables Over Time=
 
=Plot Variables Over Time=
 
* Line plots
 
* Line plots
** Filters/ Data Analysis/ Plot over Line.  Apply.
+
** Filters/ Data Analysis/ '''Plot over Line''''''Apply'''.
** Display tab.  Only plot Disp (Mag).
+
** Display tab.  Only plot '''Disp (Mag)'''.
** Properties/ Left Axis/ Layout.  Specify the Axis Range.
+
** Properties/ Left Axis/ Layout. (Properties is the icon at the upper left of the graph viewport, named "Edit View Options".) Specify the Axis Range.
  
 
* Node plots
 
* Node plots
 
** Delete Plot over Line.
 
** Delete Plot over Line.
** Change Surface to Surface with Edges.
+
** Change Surface to '''Surface with Edges'''.
** Select Points On.  Zoom way in (There is a bug in ParaView, and you may select too many points.)
+
** '''Select Points On'''. This is the icon that is below the Animation menu item.  (This icon is also found in the Edit menu.) Zoom way in (There is a bug in ParaView, and you may select too many points.) Rubber band select the point.
** Filters/ Data Analysis/ Plot Selection over Time.  Apply.
+
** Filters/ Data Analysis/''' Plot Selection over Time''''''Apply'''.
** Display tab.  Only plot Disp (Mag).
+
** Display tab.  Only plot '''Disp (Mag)'''.
  
 
* Spreadsheet view once again.
 
* Spreadsheet view once again.
** Split vertical
+
** '''Split vertical'''.
** Spreadsheet View.
+
** '''Spreadsheet View'''.
 
** On the Display tab, select '''Show only selected elements'''.
 
** On the Display tab, select '''Show only selected elements'''.
 
** Notice that you can see all of your Cell and Point data.
 
** Notice that you can see all of your Cell and Point data.
  
 
=Odds and ends=
 
=Odds and ends=
* Select a specific globalNodeId
+
* Select a specific globalElementId
** Select Cells On, then select a cell.
+
** '''Select Cells On''', then select a cell.
** View/ Selection Inspector.
+
** View/ '''Selection Inspector'''.
** Cell Label/ Visible.  Label Mode: GlobalElementId. Point Label/ Visible.  Label Mode: GlobalNodeIds.
+
** '''Cell Label'''/ '''Visible''''''Label Mode''': GlobalElementId. '''Point Label'''/ '''Visible''''''Label Mode''': GlobalNodeIds.
** Selection Type/ Global Ids.  Leave Field Type as Cell.
+
** '''Selection Type'''/ '''Global Ids'''.  Leave Field Type as Cell.
** Highlight the global IDs number in the input box, and type 100.
+
** Highlight the '''global IDs''' number in the input box, and type '''100'''.
 
** Cell Label/ Not Visible.  Point Label/ Not Visible.
 
** Cell Label/ Not Visible.  Point Label/ Not Visible.
  
 
* Extract Selection
 
* Extract Selection
** Reset
+
** '''Reset'''
** Select Cells Through.  Select the middle of the tube.
+
** '''Select Cells Through'''.  Select the middle of the tube.
** Filters/ Data Analysis/ Extract Selection.
+
** Filters/ Data Analysis/ '''Extract Selection'''.
 +
 
 +
* Clip filter
 +
** Filters/ Data Analysis/ '''Clip'''.  '''Apply'''.
 +
 
 +
* Arrows that point TO a surface - Advanced Topic
 +
** There is a feature hole in ParaView that has a feature request pending.  The glyph filter always has arrows pointing from a surface, not towards a surface.  Here is a way to create arrows that point to a surface (for instance, pressure on the surface of an underwater pipe):
 +
** Bring in your data that has pressure vectors, such as Force.
 +
** Sources/ '''Arrow'''.  Apply.
 +
** Filters/ Alphabetical/ '''Transform'''.  Translate X == '''-1'''.  '''Apply'''.
 +
** Select your data in the Pipeline Browser once again.
 +
** Filter/ '''Glyph With Custom Source'''.
 +
** Click the button left to the word Source.  In the left window, select '''Transform'''.  '''OK'''. 
 +
** Select your Vector input, and hit '''Apply'''.
 +
 
  
 
* Questions?
 
* Questions?
 +
 +
=Acknowledgements=
 +
Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.

Latest revision as of 20:04, 11 August 2009

Introduction

This tutorial will describe the following:

  • How to start ParaView and find information and help about ParaView
  • Animate modes.
  • Animate time data.
  • Plot data, including variable data vs time and plot over line.
  • Odds and Ends.

How to start ParaView

  • Start ParaView.
    • On Linux and Mac, go into the ParaView directory (that you downloaded to above) and type “paraview”.
    • On Windows XP, go to Start → All Programs → ParaView 3.x.x → and click ParaView
  • Open OsShip-eig.exo.
    • In ParaView, File → Open. Go to OsShip-eng.exo, and select it. Click OK.
    • Under the Properties tab of the Object Inspector, select all Variables
    • Click Apply.
    • Rotate the ship with the left mouse button, Scale the ship with the right mouse button.

Animate modes

  • Mode Shape controls
    • Under the Properties tab is a section called Mode Shapes.
    • Check "Has Mode Shapes". Apply.
    • Note that you have to select the Apply button whenever it has turned green. Whenever you turn on Mode Shapes, or change Mode, you will have to select the Apply button.
    • Also notice that ParaView Mode Shapes are 0 based. Thus, take any Mode that you want to see and subtract 1. (I hope that this will change to be 1 based in the near future.)
    • Animate. This is the right pointing green triangles in the middle of the toolbars at the top of the screen that has the label Play. Try setting Mode to 2, then 3, then 4, and animate. (Don't forget that ParaView input is 0 based!)
  • Spreadsheet
    • Select the Split vertical icon (located in the upper right corner of the 3d viewport).
    • Spreadsheet view.
    • Make sure the eyeball next to the part name in the Pipeline Browser is turned on.
    • Change Attribute to Field Data.
  • Show pressure on sub-eig.exo sideset.
    • Close the Spreadsheet view.
    • Edit/ Delete All.
    • Open sub-eig.exo. Turn on all variables, Apply.
    • Open sub-eig.exo again. Turn all variables on. Turn all blocks off, turn all sidesets On. Apply.
    • Choose the first dataset. Change Surface to Wireframe. Next, change the Wireframe to Points. On the Display tab, change Point Size to 1.
    • Choose the second dataset.
    • Filters/ Common/ Glyph filter. Apply.
    • The Scale Factor is too small. On the Properties tab, click Edit, and change the Scale Factor to 0.5. Apply.
    • Reset Icon (below and right of the counterclockwise red arrow)
    • Animate.

Animate Time

    • Edit/ Delete All.
    • Open sub-trans.exo. Turn on all variables, Apply.
    • Lets color by displacement. Change Solid Color to disp, in the pulldown box below the Sources menu.
    • Sources/ Annotate Time.
    • Animate.
    • You should see no change. There are two reasons:
      • The displacement is too small. Go back to time step 0. On the Properties tab, change Apply Displacements to 50 magnitude. Animate.
      • The displacement min and max are not set correctly. The quickest way to fix this is to go to the last time step, and hit the Rescale to Data Range icon (below the View menu). Next, hit the Color Legend icon (below the File menu). Now, go back to time step 0, and animate.
    • Try coloring by aForce. Notice that time step 0 has the correct data, NOT the last time step.
  • Save screenshot and save movie
    • File/ Save Screenshot.
    • File/ Save Animation.

Plot Variables Over Time

  • Line plots
    • Filters/ Data Analysis/ Plot over Line. Apply.
    • Display tab. Only plot Disp (Mag).
    • Properties/ Left Axis/ Layout. (Properties is the icon at the upper left of the graph viewport, named "Edit View Options".) Specify the Axis Range.
  • Node plots
    • Delete Plot over Line.
    • Change Surface to Surface with Edges.
    • Select Points On. This is the icon that is below the Animation menu item. (This icon is also found in the Edit menu.) Zoom way in (There is a bug in ParaView, and you may select too many points.) Rubber band select the point.
    • Filters/ Data Analysis/ Plot Selection over Time. Apply.
    • Display tab. Only plot Disp (Mag).
  • Spreadsheet view once again.
    • Split vertical.
    • Spreadsheet View.
    • On the Display tab, select Show only selected elements.
    • Notice that you can see all of your Cell and Point data.

Odds and ends

  • Select a specific globalElementId
    • Select Cells On, then select a cell.
    • View/ Selection Inspector.
    • Cell Label/ Visible. Label Mode: GlobalElementId. Point Label/ Visible. Label Mode: GlobalNodeIds.
    • Selection Type/ Global Ids. Leave Field Type as Cell.
    • Highlight the global IDs number in the input box, and type 100.
    • Cell Label/ Not Visible. Point Label/ Not Visible.
  • Extract Selection
    • Reset
    • Select Cells Through. Select the middle of the tube.
    • Filters/ Data Analysis/ Extract Selection.
  • Clip filter
    • Filters/ Data Analysis/ Clip. Apply.
  • Arrows that point TO a surface - Advanced Topic
    • There is a feature hole in ParaView that has a feature request pending. The glyph filter always has arrows pointing from a surface, not towards a surface. Here is a way to create arrows that point to a surface (for instance, pressure on the surface of an underwater pipe):
    • Bring in your data that has pressure vectors, such as Force.
    • Sources/ Arrow. Apply.
    • Filters/ Alphabetical/ Transform. Translate X == -1. Apply.
    • Select your data in the Pipeline Browser once again.
    • Filter/ Glyph With Custom Source.
    • Click the button left to the word Source. In the left window, select Transform. OK.
    • Select your Vector input, and hit Apply.


  • Questions?

Acknowledgements

Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.