Difference between revisions of "ParaView Release Notes"

From KitwarePublic
Jump to: navigation, search
(New page: == ParaView 3.2.0 (Beta) == === Download Links === * [http://paraview.org/files/v3.2/paraview-3.2.0-win32-x86.exe Windows binary] * [http://paraview.org/files/v3.2/paraview-3.2.0-Linux-x8...)
 
Line 1: Line 1:
 +
== ParaView 3.2.1 ==
 +
 +
Hi Folks,
 +
 +
Kitware, Sandia National Laboratories, CSimSoft and Los Alamos Laboratory
 +
are proud to announce the release of ParaView 3.2.1 (stable). You can
 +
download it from
 +
http://paraview.org/HTML/Download.html.
 +
 +
This release includes the following enhancements/fixes:
 +
 +
* New animation view for viewing, creating, modifying animations. This
 +
is improved version of the ParaView 2.6 animation tracks. We have made
 +
it more intuitive and easier to use.
 +
* The "Element Inspector" has been replaced by brand new "Spreadsheet"
 +
view which makes it possible to view the raw data produced by any
 +
source/filter.
 +
* Filters with multiple outputs and inputs are now supported. This
 +
opened doors for several new filter such as glyph with custom source,
 +
stream tracer with custom point source etc.
 +
* There are several improvements to charts including support for vector
 +
data in line charts (magnitude or component), support for labels, titles
 +
and legends, custom chart axes end points.
 +
* Selection support has undergone a major overhaul. It is now possible
 +
to select cells (or points) on surface of geometry or within a view
 +
frustum by simply dragging on the 3D view. The properties of the
 +
selection can be inspected/changed using the brand new "Selection
 +
Inspector" accessible through the "View" menu. "Extract Selection"
 +
filter can be used to extract the selected cells or points. Labels can
 +
be used to label the selected cells or points.
 +
* Support for eXtensible Data model and Format (XDMF) files is back and
 +
improved to support composite datasets, quadratic elements, mixed
 +
topologies. It is now possible to change domain and grid selections as well.
 +
* We are working on making ParaView totally at ease with composite data
 +
sets. As a part of the process histogram (and soon probe) filters now
 +
work with composite datasets. The python client can fetch composite
 +
datasets as well as perform operations such as min/max/sum on these dataset.
 +
* A new python module is introduced which makes dealing with proxies
 +
convenient. A separate document is available describing these python
 +
enhancements.
 +
* This version has many GUI usability improvements including but
 +
definitely not limited to:
 +
- view based and application settings.
 +
- using mouse clicks for picking center of rotation, point widget
 +
location.
 +
* We are constantly trying to make the documentation better. The online
 +
help has been extended to include the new functionality added since 3.0.
 +
 +
We would like to acknowledge Sandia Labs and Los Alamos Lab for their
 +
continuing support and funding.
 +
 +
Enjoy.
 +
 
== ParaView 3.2.0 (Beta) ==
 
== ParaView 3.2.0 (Beta) ==
  

Revision as of 13:22, 19 September 2008

ParaView 3.2.1

Hi Folks,

Kitware, Sandia National Laboratories, CSimSoft and Los Alamos Laboratory are proud to announce the release of ParaView 3.2.1 (stable). You can download it from http://paraview.org/HTML/Download.html.

This release includes the following enhancements/fixes:

  • New animation view for viewing, creating, modifying animations. This

is improved version of the ParaView 2.6 animation tracks. We have made it more intuitive and easier to use.

  • The "Element Inspector" has been replaced by brand new "Spreadsheet"

view which makes it possible to view the raw data produced by any source/filter.

  • Filters with multiple outputs and inputs are now supported. This

opened doors for several new filter such as glyph with custom source, stream tracer with custom point source etc.

  • There are several improvements to charts including support for vector

data in line charts (magnitude or component), support for labels, titles and legends, custom chart axes end points.

  • Selection support has undergone a major overhaul. It is now possible

to select cells (or points) on surface of geometry or within a view frustum by simply dragging on the 3D view. The properties of the selection can be inspected/changed using the brand new "Selection Inspector" accessible through the "View" menu. "Extract Selection" filter can be used to extract the selected cells or points. Labels can be used to label the selected cells or points.

  • Support for eXtensible Data model and Format (XDMF) files is back and

improved to support composite datasets, quadratic elements, mixed topologies. It is now possible to change domain and grid selections as well.

  • We are working on making ParaView totally at ease with composite data

sets. As a part of the process histogram (and soon probe) filters now work with composite datasets. The python client can fetch composite datasets as well as perform operations such as min/max/sum on these dataset.

  • A new python module is introduced which makes dealing with proxies

convenient. A separate document is available describing these python enhancements.

  • This version has many GUI usability improvements including but

definitely not limited to:

- view based and application settings.
- using mouse clicks for picking center of rotation, point widget

location.

  • We are constantly trying to make the documentation better. The online

help has been extended to include the new functionality added since 3.0.

We would like to acknowledge Sandia Labs and Los Alamos Lab for their continuing support and funding.

Enjoy.

ParaView 3.2.0 (Beta)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-3-2-0 ParaView3
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-3-2-0 ParaViewData

Announcement

Kitware, Sandia National Laboratories and CSimSoft are proud to announce the release of ParaView 3.2 beta. You can download it from http://paraview.org/HTML/Download.html. This is our first candidate for the 3.2 release. We hope to release 3.2 in 2 weeks. You can find release notes from previous alpha releases here: http://paraview.org/Wiki/ParaView_III_snapshots and some more information about ParaView 3 here: http://paraview.org/Wiki/ParaView_III

This release includes the following enhancements/fixes:

  • New animation view for viewing, creating, modifying animations. This is improved version of the ParaView 2.6 animation tracks. We have made it more intuitive and easier to use.
  • The "Element Inspector" has been replaced by brand new "Spreadsheet" view which makes it possible to view the raw data produced by any source/filter.
  • Filters with multiple outputs and inputs are now supported. This opened doors for several new filter such as glyph with custom source, stream tracer with custom point source etc.
  • There are several improvements to charts including support for vector data in line charts (magnitude or component), support for labels, titles and legends, custom chart axes end points.
  • Selection support has undergone a major overhaul. It is now possible to select cells (or points) on surface of geometry or within a view frustum by simply dragging on the 3D view. The properties of the selection can be inspected/changed using the brand new "Selection Inspector" accessible through the "View" menu. "Extract Selection" filter can be used to extract the selected cells or points. Labels can be used to label the selected cells or points.
  • Support for eXtensible Data model and Format (XDMF) files is back and improved to support composite datasets, quadratic elements, mixed topologies. It is not possible to change domain and grid selections as well.
  • We are working on making ParaView totally at ease with composite data sets. As a part of the process histogram and probe filters now work with composite datasets. The python client can fetch composite datasets as well as perform operations such as min/max/sum on these dataset.
  • A new python module is introduced which makes dealing with proxies convenient. A separate document is available describing these python enhancements.
  • This version has many GUI usability improvements including but definitely not limited to:
    • view based and application settings.
    • using mouse clicks for picking center of rotation, point widget location.
  • We are constantly trying to make the documentation better. The online help has been extended to include the new functionality added since 3.0.

We would like to acknowledge Sandia Labs and Los Alamos Lab for their continuing support and funding.


Have fun.

July snapshot - ParaView 3.1.0

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-3-1-July ParaView3

Announcement

Development snapshot of ParaView III for July (3.1.0) is now available. The download links and announcements for all snapshots can be found at: http://paraview.org/Wiki/ParaView_III_snapshots (also at http://paraview.org/New/download.html)

This snapshot includes binaries for Windows, Linux (32 and 64 bit) and Mac OS X and tar/zip balls for the source. The source can be obtained through CVS using tag "ParaView-3-1-July".

Here are some the things we have been working on:

  • Improved chart controls. Most of the changes to the charts won't be visible to the user for the July snapshot. The interaction setup has changed. Pan, zoom, and zoom box are on the left, middle, and right mouse buttons respectively. The default colors for the line charts have changed.
  • Better controls to layout text annotations.
  • Improvements to the underlying rendering framework making it easier to add new views/representations.

Here's what coming soon:

  • Improved animation track editor.
  • Multiple input/multiple output support.
  • Better element inspector to inspecting an entire dataset.
  • Support for labeling points/cells.
  • More chart improvements including:
    • Setting the line style and thickness on the line charts,
    • More axis layout control. (log scale, setting the range),
    • Legend,
    • Labels.

Look at http://www.paraview.org/Wiki/ParaView_III to get more information on the new features. We will continue adding more documentation to this page as we progress.

Have fun.

March snapshot - ParaView 2.9.9 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-March ParaView3

Announcement

Hi Folks,

Berk has posted the March snapshot of ParaView III.

This snapshot includes binaries for Windows, Linux and Mac OS X (intel only). The source can be obtained through CVS.

Here are some the things we have been working on:

  • Support for Plugins: ParaView 3 provides a much more powerful plugin support than that provided by ParaView 2. Examples are provided along with the source (in ParaView3/Examples/Plugins). Detailed documentation is available at http://www.paraview.org/Wiki/Plugin_HowTo
  • Extended Animation support: ParaView 3 now makes it possible to animate Camera, Cut/Clip planes etc. There is no track editor at this point.
  • Selection: We are working on improving the selection mechanism. Currently users can select cells/points by ids, location, or thresholds. Surface as well as frustum selections through the data are now possible.
  • Plotting: Plot views are now a part of the main view. Splitting a view no longer creates a 3D render view by default. User can change the view type by right clicking on the view's title bar. Any 1D rectilinear grid data can now be plotted either as a XY line plot or a Bar chart.
  • Improved dialog for editing color lookup tables.
  • Xdmf Reader: Support for reading Xdmf files has now been enabled.

What is coming next month:

  • More selection enahancements.
  • Fixes/improvements to the Undo/Redo framework.
  • Volume rendering interface
  • Improved color map editor

On another note, ParaView 3 now requires Qt 4.2.2 to build.

There is still very little documentation. Look at http://www.paraview.org/Wiki/ParaView_III to get more information on the new features. We will continue adding more documentation to this page as we progress. We started working on Qt assistant based online documentation. It will be available soon.

Have fun.

February snapshot - ParaView 2.9.8 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-February ParaView3

Announcement

Hi Folks,

I posted the January snapshot of ParaView III.

This snapshot includes binaries for Windows, Linux and Mac OS X (intel only, I will start posting ppc binaries again next month). The source can be obtained through CVS.

Here are some the things we have been working on:

  • Animation support: ParaView 3 has now an animation panel very similar to ParaView 2. There is not track editor at this point.
  • Improved time support: We are working on integrating recent time-support changes in the VTK pipeline to ParaView. You will notice that some of the readers no longer have a time step property. This is because the time editing capabilities are moving to the animation panel.
  • Improved python support including client-side delivery. The python API is evolving very rapidly, once it matures, we will post documentation.
  • Property and camera linking. This is a very cool feature. Check the wiki for documentation.

What is coming next month:

  • Lookmark support
  • Much improved 2D plotting support
  • Volume rendering interface
  • Improved color map editor
  • Plugins

On another note, ParaView 3 now requires Qt 4.2.2 to build.

There is still very little documentation. Look at http://www.paraview.org/Wiki/ParaView_III to get more information on the new features. We will continue adding more documentation to this page as we progress. We started working on Qt assistant based online documentation. It will be available soon.

Have fun.

January snapshot - ParaView 2.9.7 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-January ParaView3

Announcement

Hi Folks,

I posted the January snapshot of ParaView III. 

This snapshot includes binaries for Windows, Linux (32 and 64 bit) and
Mac OS X. The source can be obtained through CVS.

Here are some the things we have been working on:

* Improved python support. We added a programmable python filter. The
python source can be entered on the object inspector.
* Better default values for the object inspector. These are computed
based on the input. For example, the default maximum length of the
streamlines is now computed based on the input size.
* Pipeline browser improvements:
  - it is now possible to change inputs as well as add multiple
inputs to filters that support it
* Further GUI improvements
* First pass at annotation: we added a text source. This allows
creation of an arbitrary number of labels on the display. The text can
be moved by clicking and dragging. There are some glitches with the
interaction. We will fix this soon.

There is still very little documentation. Look at
http://www.paraview.org/Wiki/ParaView_III to get more information on the new
features. We will continue adding more documentation to this page as
we progress. We will also start working on online documentation this month.

Have fun.

December snapshot - ParaView 2.9.6 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-December ParaView3

Announcement

Hi Folks,

I posted the December snapshot of ParaView III. 

This snapshot includes binaries for Windows, Linux (32 and 64 bit) and
Mac OS X. The source can be obtained through CVS.

Here are some the things we have been working on:

* Reading multiple exodus files.
* Many property panel improvements and fixes.
* File dialog fixes.
* Improved chart code.
* Improved testing framework, which now includes python.
* Improved pipeline browser.
* Play/Pause in VCR controls.
* Light Kit controls added.
* Auto generated and custom panel improvements.
* More robust server connection, w/ feedback.
* File dialog improvements.

There is still very little documentation. Look at
http://www.paraview.org/Wiki/ParaView_III to get more information on the new
features. We will continue adding more documentation to this page as
we progress. We will also start working on online documentation in
January.

November snapshot - ParaView 2.9.5 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-November ParaView3

Announcements

Hi Folks,

Due to IEEE Vis and Supercomputing conferences, we were late putting
out a snapshot this month. 
This is mostly a bug fix release. Some the new features and fixes include:

* Reading multiple exodus files.
* Many property panel improvements and fixes.
* File dialog fixes.
* Improved chart code.
* Improved testing framework, which now includes python.


October snapshot - ParaView 2.9.4 (alpha)

Download Links

Source code

Checkout using CVS:

> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 login
CVS password: paraview
> cvs -d :pserver:anonymous@paraview.org:/cvsroot/ParaView3 co -r ParaView-2-9-October ParaView3

Announcements

Hi Folks,

I posted the October snapshot of ParaView III. 

This snapshot includes binaries for Windows, Linux (32 and 64 bit) and Mac OS X.
I did not post the source because the CVS repository is now open to anonymous
access (yey!). Follow the instructions on the page to checkout the source from CVS.

New features to look for include:

* Addition of Display and Information tabs similar to ParaView 2. We are still
trying to decide what to do with these pages so the way they work may change in
the future. It is still possible to access the statistics page from
View->Statistics View and the display page from the contextual menu of
individual pipeline elements (right click -> Display Settings). We would love
feedback on this.
* Layout and geometry is not stored at exit and restored at startup.
* Improved property pages for readers and filters
* Preliminary support for plots. The first plot view we added is a bar plot
view. This is used only for histograms. To try it out, follow these steps:
   - Create a sphere from the sources menu
   - Apply the histogram filter (Filters->Test->ExtractHistogram)
   - Create a histogram view (Edit->Add Plot->Histogram)
   - Select the new view by clicking on it
   - Turn the visibility of the histogram filter on by clicking on the eye icon
We are working on making this process simpler :-)

There is still very little documentation. Look at
http://www.paraview.org/Wiki/ParaView_III to get more information on the new
features. We will continue adding more documentation to this page as we progress.

Enjoy.

September snapshot - ParaView 2.9.3 (alpha)

Download Links

Announcement

Hi Folks,

I posted the September snapshot of ParaView III. 

This snapshot includes binaries for Windows, Linux (32 and 64 bit) and Mac OS X. 
For those who have issues running the binaries, who cannot find the binary for their 
system or who want to see/modify the source code, source archives are also included.

New features to look out for include:

* Improved multi-view support:
  Try creating, destroying, maximizing, restoring and moving views. To move a
  view, click on it's toolbar and drag onto another view's toolbar.
* Improved server connection and start dialog
* Improved selection:
  Try turning on the element inspector before selecting,
  (View -> Element Inspector)
* More toolbar buttons including those for manipulating camera. Better icons are
  coming soon
* Separate camera undo/redo buttons for each view
* Dialog for changing application and view settings (Edit -> Settings)
* Capability to disconnect from server while saving an animation

Also check out:

* Custom filter dialog (tutorial coming)
* Undo/redo
* Custom reader/filter panels (try exodos reader, cut and clip)
* Python scripting

There is still very little documentation. Look at 
http://www.paraview.org/Wiki/ParaView_III to get more information on the 
new features. We will continue adding more documentation to this page as 
we progress.

August snapshot - ParaView 2.9.2 (alpha)

Download Links


Announcement

Hi Folks,

I posted the August snapshot of ParaView. You can download it here: (see links above)

...

We regularly compile and run Windows, Linux and MacOS X.

Please note that this is a development snapshot and may contain bugs. We have
removed some of the limitations in this snapshot. It is now possible to access
some of the features in development including multiple frames, all
readers/sources/filters, python shell (requires compilation from source).

There is still very little documentation. We will focus on that before the
actual release.

-Berk

July snapshot - ParaView 2.9.1 (alpha)

Download Links

Announcement

Hi Folks,

I posted the june snapshot of ParaView 2.9 (to be 3.0) on the web. 
There are binaries for linux (x86) and windows. Make sure you download 2.9.1.
2.9.0 is the snapshot from May. I also uploaded an exodus file
(disk_out_ref.exo). It is good file to play with to see some of the new features.

Some new features to look for (in no particular order):

* Support for more file formats (exodus reader is still the one that is tested
and customized best)
* Statistics view
* Two undo/redo stacks: 1. pipeline operations (ctrl+z, ctrl+r) 2. view
operation (ctrl+b, ctrl+f)
* Visibility control on the pipeline inspector
* Selection (still at alpha, use toolbar buttons or 's' key to switch between
interaction & selection)
* Support for more sources
* Support for contour and streamlines filters
* Support for saving & loading state
* Saving screenshot
* Saving animation. Very alpha. It only support creating animations from readers
that support time (File->Save Animation)
* Bug fixes

We are working on:

* Readers/filters
* Custom filters (being able to create custom filters by selection part of a
pipeline, saving, loading and instantiating them)
* Full featured animation
* Colormap editor
* Application/3D view settings
* Python interface
* Selection
* Server connection interface

Longer term:

* Support for multiple views
* Client side plotting using Qt widgets (2D plots, histogram)
* Multiple server connection
* Multiple client connection

Some of these features are already in alpha stage and are enabled in the CVS
development tree. I disabled them to make binaries. Use the snapshots and CVS at
your own risk. I would not recommend using 2.9 for production use. Bug reports
are obviously welcome.

June snapshot - ParaView 2.9.0 (alpha)

Download Link

Announcement

Kitware, Sandia National Labs and Elemental Technologies have been working on
ParaView 3.0 for a few months. ParaView 3.0 will have a myriad of new features
including a brand new interface. This interface is based on the Qt library
(http://www.trolltech.com/products/qt) and is designed to be easy to use and
elegant. Paraview 3.0 will also have a greatly expanded emphasis on quantitative
analysis, with lots of plotting, graphing, and linked views. We have our first
development snapshot.

Currently, we are working on a separate CVS repository so the source code for
the Qt interface is not yet available. We will open this CVS repository soon and
we will merge the two repositories sometime in the future, most probably before
the release of ParaView 2.6 in Q4 of 2006.

Please keep in mind that this is not even a beta but more a development
snapshot. We expect the development will take several more months. Comments and
feedback are as usual welcome.

Regards,
ParaView Team



ParaView: [Welcome | Site Map]