ParaView/Superbuild

From KitwarePublic
< ParaView
Revision as of 02:01, 17 August 2012 by Utkarsh (Talk | contribs)

Jump to: navigation, search

THIS PAGE IS UNDER CONSTRUCTION FOR THE UPCOMING PARAVIEW RELEASE. PLEASE CHECKBACK LATER

Introduction

This page describes how to build ParaView binaries along with most, if not all, of the external dependencies that ParaView needs to generate a full featured build of ParaView.

We use CMake External Projects to provide users/developers with a uber cmake project that can build ParaView and its dependencies and hence we refer to it as the ParaView Superbuild. For instructions on building ParaView itself, providing installed or prebuilt versions of the dependencies, refer to ParaView:Build And Install instructions.

Prerequisites

  • ParaView-Superbuild requires CMake, version 2.8.8 or higher and a working compiler. On Unix-like operating systems, it also requires Make, while on Windows it requires Visual Studio (8 or later). Follow these instructions to download and install cmake. This document assumes familiarity with using CMake.
  • On Windows, in order to enable scripting support, Python is required.