Difference between revisions of "Beginning Pictures and Movies"

From KitwarePublic
Jump to: navigation, search
Line 5: Line 5:
 
First off, start ParaView and open a data file that includes time displacement data.
 
First off, start ParaView and open a data file that includes time displacement data.
 
*Start ParaView.   
 
*Start ParaView.   
*File → Open.  We will use the data can.exo for this usecase.   
+
*'''File → Open'''.  We will use the data can.exo for this usecase.   
*Click Apply.
+
*Click '''Apply'''.
 
*Rotate and position the object.  Notice the following (if ParaView buttons still use default settings):
 
*Rotate and position the object.  Notice the following (if ParaView buttons still use default settings):
 
**Left mouse button rotates the camera in 3d space.
 
**Left mouse button rotates the camera in 3d space.
Line 15: Line 15:
 
Next, we need to move this image into PowerPoint.  This is done by saving the screen image to a file, then reading that file back into Powerpoint (or any other program, such as Microsoft Word).   
 
Next, we need to move this image into PowerPoint.  This is done by saving the screen image to a file, then reading that file back into Powerpoint (or any other program, such as Microsoft Word).   
  
Create a file holding a picture of our data.  Click File→ Save Screenshot.  Leave image quality and resolution as is.  Notice that you can save either the current view or all of the views (if we have multiple views open).  Leave as the default.  OK.  Select Files of type, *.jpg.  Name and save the file.   
+
Create a file holding a picture of our data.  Click '''File→ Save Screenshot'''.  Leave image quality and resolution as is.  Notice that you can save either the current view or all of the views (if we have multiple views open).  Leave as the default.  '''OK'''.  Select '''Files of type''', '''*.jpg'''.  Name and save the file.   
  
In PowerPoint, add a new slide.  Next, click Insert→ Picture→ From File…, and pick up the file that we saved in the previous paragraph.  You can move the file anywhere you want by holding the left mouse button and dragging.  You can resize the picture by grabbing one of the corners and dragging the picture smaller.  The following picture is from a PowerPoint slide.
+
In PowerPoint, add a new slide.  Next, click '''Insert→ Picture→ From File…''', and pick up the file that we saved in the previous paragraph.  You can move the file anywhere you want by holding the left mouse button and dragging.  You can resize the picture by grabbing one of the corners and dragging the picture smaller.  The following picture is from a PowerPoint slide.
  
 
==Save Animation==
 
==Save Animation==
Now let’s make a movie.  This movie will be a file capture of a normal animation.  Position your data on the screen.  Next, test run the animation by selecting Play, which is the right arrow, one of the animation buttons (at the top of the main window).  Finally, select File→ Save Animation and then Save Animation.  Select a file format, and click OK.   
+
Now let’s make a movie.  This movie will be a file capture of a normal animation.  Position your data on the screen.  Next, test run the animation by selecting '''Play''', which is the right arrow, one of the animation buttons (at the top of the main window).  Finally, select '''File→ Save Animation''' and then '''Save Animation'''.  Select a file format, and click '''OK'''.   
  
If you are making movies on one of the clusters, you can use option Disconnect before saving animation.  This will allow a user to create movies after the user has closed ParaView client down, and possibly turned the client computer off.
+
If you are making movies on one of the clusters, you can use option '''Disconnect before saving animation'''.  This will allow a user to create movies after the user has closed ParaView client down, and possibly turned the client computer off.
  
 
In PowerPoint, add a new slide.  Next, click “Insert/ Movies and Sounds/ Movie from File.  Browse to the location of your movie, select your file and click OK.  Decide if you want the slide show to be Automatic, or when clicked.  Finally, remember that this file is NOT inserted into the PowerPoint slide.  You will want this file to be on the computer – in the same location – as it was when you selected it.
 
In PowerPoint, add a new slide.  Next, click “Insert/ Movies and Sounds/ Movie from File.  Browse to the location of your movie, select your file and click OK.  Decide if you want the slide show to be Automatic, or when clicked.  Finally, remember that this file is NOT inserted into the PowerPoint slide.  You will want this file to be on the computer – in the same location – as it was when you selected it.
  
A few notes on file formats for movies.  You can make .avi  files directly on Windows XP.  If you are trying to make movies on Linux or Mac, or are making movies for the VisLab powerwall, use format .png or .jpg.  Then, convert these movies to .avi format as needed. One option is to use enve, which is available when downloading EnSight.  Windows XP reads .avi files well, both using and not using PowerPoint.  Linux is able to display either format if the correct video player is installed.  One option is mplayer.  mplayer is installed from .rpm files, which can be found on the net.
+
A few notes on file formats for movies.  You can make .avi  files directly on Windows XP, Linux or Mac.  If you are trying to make movies on Linux or Mac, or are making movies for a powerwall, use format .png or .jpg.  Then, if you want .avi files for use with PowerPoint, convert these movies to .avi format as needed. One option is to use enve, which is available when downloading EnSight.  Windows XP reads .avi files well, both using and not using PowerPoint.  Linux is able to display either format if the correct video player is installed.  One option is mplayer.  mplayer is installed from .rpm files, which can be found on the net.
  
 
=Acknowledgements=
 
=Acknowledgements=
 
Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.
 
Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.

Revision as of 23:01, 18 December 2008

Introduction

This usecase shows a user how to add pictures and movies to PowerPoint slides.

Save Screenshot

First off, start ParaView and open a data file that includes time displacement data.

  • Start ParaView.
  • File → Open. We will use the data can.exo for this usecase.
  • Click Apply.
  • Rotate and position the object. Notice the following (if ParaView buttons still use default settings):
    • Left mouse button rotates the camera in 3d space.
    • Right mouse button changes how far the camera is from the data.
    • <SHFT> Left mouse button rotates the camera in 2d space.
    • <SHFT> Right mouse button moves the camera around the screen in 2d space.

Next, we need to move this image into PowerPoint. This is done by saving the screen image to a file, then reading that file back into Powerpoint (or any other program, such as Microsoft Word).

Create a file holding a picture of our data. Click File→ Save Screenshot. Leave image quality and resolution as is. Notice that you can save either the current view or all of the views (if we have multiple views open). Leave as the default. OK. Select Files of type, *.jpg. Name and save the file.

In PowerPoint, add a new slide. Next, click Insert→ Picture→ From File…, and pick up the file that we saved in the previous paragraph. You can move the file anywhere you want by holding the left mouse button and dragging. You can resize the picture by grabbing one of the corners and dragging the picture smaller. The following picture is from a PowerPoint slide.

Save Animation

Now let’s make a movie. This movie will be a file capture of a normal animation. Position your data on the screen. Next, test run the animation by selecting Play, which is the right arrow, one of the animation buttons (at the top of the main window). Finally, select File→ Save Animation and then Save Animation. Select a file format, and click OK.

If you are making movies on one of the clusters, you can use option Disconnect before saving animation. This will allow a user to create movies after the user has closed ParaView client down, and possibly turned the client computer off.

In PowerPoint, add a new slide. Next, click “Insert/ Movies and Sounds/ Movie from File. Browse to the location of your movie, select your file and click OK. Decide if you want the slide show to be Automatic, or when clicked. Finally, remember that this file is NOT inserted into the PowerPoint slide. You will want this file to be on the computer – in the same location – as it was when you selected it.

A few notes on file formats for movies. You can make .avi files directly on Windows XP, Linux or Mac. If you are trying to make movies on Linux or Mac, or are making movies for a powerwall, use format .png or .jpg. Then, if you want .avi files for use with PowerPoint, convert these movies to .avi format as needed. One option is to use enve, which is available when downloading EnSight. Windows XP reads .avi files well, both using and not using PowerPoint. Linux is able to display either format if the correct video player is installed. One option is mplayer. mplayer is installed from .rpm files, which can be found on the net.

Acknowledgements

Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.