Difference between revisions of "Beginning ParaView"

From KitwarePublic
Jump to: navigation, search
(A simple example)
(17 intermediate revisions by the same user not shown)
Line 2: Line 2:
 
This tutorial will describe how to start ParaView, find information and help about ParaView, and describe some of the more important controls used by ParaView.
 
This tutorial will describe how to start ParaView, find information and help about ParaView, and describe some of the more important controls used by ParaView.
  
The ParaView web site is located at www.paraview.org.  New versions of ParaView can be found here, along with different tutorials and advice.  ParaView versions include 32 and 64 bit versions of Linux, Windows XP and Mac OS X.  Training (practice) data is also found here.   
+
The ParaView web site is located at http://www.paraview.org.  New versions of ParaView can be found here, along with different tutorials and advice.  ParaView versions include 32 and 64 bit versions of Linux, Windows XP and Mac OS X.  Training (practice) data is also found here.  These tutorials are found here: http://www.paraview.org/Wiki/SNL_ParaView_3_Tutorials
 
+
ParaView now has an integrated help.  It is found under the menu item Help→ Help.
+
  
 +
ParaView now has an integrated help.  It is found under the menu item '''Help→ Help'''.
  
 
=A simple example=
 
=A simple example=
 
*Start ParaView.   
 
*Start ParaView.   
 
**On Linux and Mac, go into the ParaView directory (that you downloaded to above) and type “paraview”.
 
**On Linux and Mac, go into the ParaView directory (that you downloaded to above) and type “paraview”.
**On Windows XP, go to Start → All Programs → ParaView 3.x.x → and click ParaView
+
**On Windows XP, go to '''Start → All Programs → ParaView 3.x.x →''' and click '''ParaView'''
 +
 
 
*Open can.ex2.   
 
*Open can.ex2.   
 
**can.ex2 is one of the datasets in the training data, found on the web site under “Installing ParaView”.
 
**can.ex2 is one of the datasets in the training data, found on the web site under “Installing ParaView”.
**In ParaView, File → Open.  Go to can.ex2, and select it.  Click OK.
+
**In ParaView, '''File → Open'''.  Go to can.ex2, and select it.  Click OK.
**Under the Properties tab of the Object Inspector, select all Variables
+
**Under the '''Properties''' tab of the '''Object Inspector''', select all '''Variables'''
**Click Apply.
+
**Click '''Apply'''.
 +
 
 +
 
 +
[[Image:beginning_paraview_1.png]]
  
<!--Picture goes here-->
 
  
 
*Turn off the node variables for ACCL.  Since any variable that is selected takes up memory, and since some datasets are huge, often the user will only read in the data that is needed for a run.
 
*Turn off the node variables for ACCL.  Since any variable that is selected takes up memory, and since some datasets are huge, often the user will only read in the data that is needed for a run.
**Click ACCL, turning the check box OFF.
+
**Click '''ACCL''', turning the check box OFF.
**Apply.
+
**'''Apply'''.
 +
 
 +
*The screen should now look like this.  (The square will show up as grey, since ParaView defaults to coloring by a solid color.)  You are looking at the bottom of the plate that the can is sitting on.
  
*The screen should now look like this.  (The square will show up as grey, since ParaView 3.4 defaults to coloring by a solid color.)  You are looking at the bottom of the plate that the can is sitting on.
 
 
   
 
   
<!--Picture goes here-->
+
[[Image:beginning_paraview_2.png|800px]]
  
  
*Grab the can using the left mouse button.  Try the center button.  Try again with the right button.  Try all three again holding down the <SHFT> key.  Try with the <CTRL> key down.
+
*Grab the can using the left mouse button.  Try the center button.  Try again with the right button.  Try all three again holding down the '''<SHFT>''' key.  Try with the '''<CTRL>''' key down.
*To change the display style, select the Display tab of the Object Inspector.  In the Style section find Representation, left click on the button (it probably says Surface).  Change this to Wireframe.  Then, change it to Surface with Edges.  Finally, turn it back to Surface.
+
*To change the representation, change '''Surface''' to '''Wireframe''' (right below '''Help''').  Then, change it to '''Surface with Edges'''.  Finally, turn it back to '''Surface'''.
*Change the variable used for color.  Under the Display tab, in the Color section, select Color by.  Change this to Displacement (Point DISPL).  Everything should go red.
+
*Change the variable used for color.  Change this from '''Solid Color''' to Displacement (Point '''DISPL'''). (This is found just below the '''Sources''' menu.) Everything should go red.
  
*Note that you can do the same thing using the Active Variable and Representation toolbars.  The Active Variable toolbar also holds the Color Legend Visibility button, the vertical rainbow bar to the left.  Select the Color Legend Visibility button.
+
[[Image:beginning_paraview_3.png]]
  
<!--Picture goes here-->
 
 
 
   
 
   
 
*Animate the can one frame.  Right above the window of the can are animation controls.  Click the right arrow with a bar to its left once.  The plate stays red.
 
*Animate the can one frame.  Right above the window of the can are animation controls.  Click the right arrow with a bar to its left once.  The plate stays red.
  
<!--Picture goes here-->
 
 
  
**WHAT IS HAPPENING:  The ex2 dataset has displacement information in it.  We are actually running the plate into the can, and the whole object is moving.
+
[[Image:beginning_paraview_4.png]]
 +
 
 +
 
 +
**WHAT IS HAPPENING:  The can dataset has displacement information in it.  We are actually running the plate into the can, and the whole object is moving.
 
**TIP: Our color map is not set correctly, for two reasons.   
 
**TIP: Our color map is not set correctly, for two reasons.   
 
***It needs to be set over the whole range of displacement, so that it grades from blue to red.
 
***It needs to be set over the whole range of displacement, so that it grades from blue to red.
 
***Since we have not animated through all time steps, ParaView doesn’t know the range of displacements that it needs to deal with.  The next few steps will demonstrate this.  This ONLY works if you have NOT run through the full animation yet.
 
***Since we have not animated through all time steps, ParaView doesn’t know the range of displacements that it needs to deal with.  The next few steps will demonstrate this.  This ONLY works if you have NOT run through the full animation yet.
***WARNING: Very, very large data can take a long time to process.  Don’t animate your data unless you have to with very large datasets.
+
***'''WARNING:''' Very, very large data can take a long time to process.  Don’t animate your data unless you have to with very large datasets.
**Click the Rescale to Data Range color button.  The slab turns red, and the can turns blue.  We have reset our color range using the second frame of the animation.  Note that the Rescale to Data Range can be found as a button in the Active Variable Controls toolbar.
+
**Click the '''Rescale to Data Range''' color button.  The slab turns red, and the can turns blue.  We have reset our color range using the second frame of the animation.  Note that the '''Rescale to Data Range''' can be found as a button in the '''Active Variable Controls''' toolbar.
+
<!--Picture goes here-->
+
  
**Click the single right arrow, running to the end of the simulation.
 
 
   
 
   
<!--Picture goes here-->
+
[[Image:beginning_paraview_5.png]]
  
 +
 +
**Click the single right arrow, running to the end of the simulation.
 
**Click the “Rescale to Data Range”.
 
**Click the “Rescale to Data Range”.
 
**Rewind using the furthest left arrow, then click the single right arrow again.
 
**Rewind using the furthest left arrow, then click the single right arrow again.
 +
*Check Information.  Click on the '''Information''' tab of the '''Object Inspector'''.  This tells us that we have an unstructured grid, the number of cells, the number of points, and the amount of memory used.  It also tells us what type of data we have, and the ranges for this data.  We also see the time in each time step.
 +
*Move the object to the left (using the middle mouse button).  Zoom in on the object (using the right mouse button).  Then, click the Reset icon.    Select the +X icon, the –X icon, etc.
 
   
 
   
<!--Picture goes here-->
+
*Rotate the can again so you can see it.  Select the menu option '''Filters → Common → Clip'''.  Press '''Apply'''.  Animate the object with the right arrow button found above the drawing window.  '''Reset''' the animation.  Uncheck the '''Show Plane''' checkbox, located under '''Properties''' to the left.  Play the animation once again.
  
  
 +
[[Image:beginning_paraview_6.png]]
  
*Check Information.  Click on the Information tab of the Object Inspector.  This tells us that we have an unstructured grid, the number of cells, the number of points, and the amount of memory used.  It also tells us what type of data we have, and the ranges for this data.  We also see the time in each time step.
 
*Move the object to the left (using the middle mouse button).  Zoom in on the object (using the right mouse button).  Then, click the Reset icon.    Select the +X icon, the –X icon, etc.
 
 
*Rotate the can again so you can see it.  Select the menu option Filters → Common → Clip.  Press Apply.  Animate the object with the right arrow button found above the drawing window.  Reset the animation.  Uncheck the Show Plane checkbox, located under Properties to the left.  Play the animation once again.
 
  
  
 +
[[Image:beginning_paraview_7.png|800px]]
  
 
 
=Extra credit=
 
=Extra credit=
 
*Play around with other filters.
 
*Play around with other filters.
*Add a time annotation.  Select Sources → Annotate Time.  Apply.  Drag the time annotation wherever you want it. Notice the time annotation in the picture below.
+
*Add a time annotation.  Select '''Sources → Annotate Time''''''Apply'''.  Drag the time annotation wherever you want it. Notice the time annotation in the picture below.
*Add a text annotation.  Select Sources → Text.  Type in the Text box.  Hit the Apply button.  Drag the text where you want it.  You can change the font using the Display tab.  Next, try a Sources → 3d Text.  In the picture shown below, “Really quiet, hush…” is a Text Source, as is “SSSSShhhhh” and “Private!!!”.  These can be placed anywhere on the display window.  The “More quiet stuff” is a 3d Text source.
+
*Add a text annotation.  Select '''Sources → Text'''.  Type in the '''Text''' box.  Hit the '''Apply''' button.  Drag the text where you want it.  You can change the font using the '''Display''' tab.  Next, try a '''Sources → 3d Text'''.  In the picture shown below, “Really quiet, hush…” is a Text Source, as is “SSSSShhhhh” and “Private!!!”.  These can be placed anywhere on the display window.  The “More quiet stuff” is a '''3d Text''' source.
  
 +
 +
[[Image:beginning_paraview_8.png|800px]]
 
   
 
   
  
 
Where do you go next?
 
Where do you go next?
Filters tutorial.
+
*Filters tutorial.
GUI tutorial.
+
*GUI tutorial.
Client server tutorial.
+
*Client server tutorial.
Making 2d plots tutorial.
+
*Making 2d plots tutorial.
Making Powerpoint slides tutorial.
+
*Making Powerpoint slides tutorial.
 +
 
  
 +
=Acknowledgements=
 
Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.
 
Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.

Revision as of 18:43, 14 January 2011

Introduction

This tutorial will describe how to start ParaView, find information and help about ParaView, and describe some of the more important controls used by ParaView.

The ParaView web site is located at http://www.paraview.org. New versions of ParaView can be found here, along with different tutorials and advice. ParaView versions include 32 and 64 bit versions of Linux, Windows XP and Mac OS X. Training (practice) data is also found here. These tutorials are found here: http://www.paraview.org/Wiki/SNL_ParaView_3_Tutorials

ParaView now has an integrated help. It is found under the menu item Help→ Help.

A simple example

  • Start ParaView.
    • On Linux and Mac, go into the ParaView directory (that you downloaded to above) and type “paraview”.
    • On Windows XP, go to Start → All Programs → ParaView 3.x.x → and click ParaView
  • Open can.ex2.
    • can.ex2 is one of the datasets in the training data, found on the web site under “Installing ParaView”.
    • In ParaView, File → Open. Go to can.ex2, and select it. Click OK.
    • Under the Properties tab of the Object Inspector, select all Variables
    • Click Apply.


Beginning paraview 1.png


  • Turn off the node variables for ACCL. Since any variable that is selected takes up memory, and since some datasets are huge, often the user will only read in the data that is needed for a run.
    • Click ACCL, turning the check box OFF.
    • Apply.
  • The screen should now look like this. (The square will show up as grey, since ParaView defaults to coloring by a solid color.) You are looking at the bottom of the plate that the can is sitting on.


Beginning paraview 2.png


  • Grab the can using the left mouse button. Try the center button. Try again with the right button. Try all three again holding down the <SHFT> key. Try with the <CTRL> key down.
  • To change the representation, change Surface to Wireframe (right below Help). Then, change it to Surface with Edges. Finally, turn it back to Surface.
  • Change the variable used for color. Change this from Solid Color to Displacement (Point DISPL). (This is found just below the Sources menu.) Everything should go red.

Beginning paraview 3.png


  • Animate the can one frame. Right above the window of the can are animation controls. Click the right arrow with a bar to its left once. The plate stays red.


Beginning paraview 4.png


    • WHAT IS HAPPENING: The can dataset has displacement information in it. We are actually running the plate into the can, and the whole object is moving.
    • TIP: Our color map is not set correctly, for two reasons.
      • It needs to be set over the whole range of displacement, so that it grades from blue to red.
      • Since we have not animated through all time steps, ParaView doesn’t know the range of displacements that it needs to deal with. The next few steps will demonstrate this. This ONLY works if you have NOT run through the full animation yet.
      • WARNING: Very, very large data can take a long time to process. Don’t animate your data unless you have to with very large datasets.
    • Click the Rescale to Data Range color button. The slab turns red, and the can turns blue. We have reset our color range using the second frame of the animation. Note that the Rescale to Data Range can be found as a button in the Active Variable Controls toolbar.


Beginning paraview 5.png


    • Click the single right arrow, running to the end of the simulation.
    • Click the “Rescale to Data Range”.
    • Rewind using the furthest left arrow, then click the single right arrow again.
  • Check Information. Click on the Information tab of the Object Inspector. This tells us that we have an unstructured grid, the number of cells, the number of points, and the amount of memory used. It also tells us what type of data we have, and the ranges for this data. We also see the time in each time step.
  • Move the object to the left (using the middle mouse button). Zoom in on the object (using the right mouse button). Then, click the Reset icon. Select the +X icon, the –X icon, etc.
  • Rotate the can again so you can see it. Select the menu option Filters → Common → Clip. Press Apply. Animate the object with the right arrow button found above the drawing window. Reset the animation. Uncheck the Show Plane checkbox, located under Properties to the left. Play the animation once again.


Beginning paraview 6.png


Beginning paraview 7.png

Extra credit

  • Play around with other filters.
  • Add a time annotation. Select Sources → Annotate Time. Apply. Drag the time annotation wherever you want it. Notice the time annotation in the picture below.
  • Add a text annotation. Select Sources → Text. Type in the Text box. Hit the Apply button. Drag the text where you want it. You can change the font using the Display tab. Next, try a Sources → 3d Text. In the picture shown below, “Really quiet, hush…” is a Text Source, as is “SSSSShhhhh” and “Private!!!”. These can be placed anywhere on the display window. The “More quiet stuff” is a 3d Text source.


Beginning paraview 8.png


Where do you go next?

  • Filters tutorial.
  • GUI tutorial.
  • Client server tutorial.
  • Making 2d plots tutorial.
  • Making Powerpoint slides tutorial.


Acknowledgements

Sandia is a multiprogram laboratory operated by Sandia Corporation, a Lockheed Martin Company, for the United States Department of Energy’s National Nuclear Security Administration under contract DE-AC04-94AL85000.