View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006783ParaView(No Category)public2008-04-09 17:472009-05-13 13:59
ReporterKen Moreland 
Assigned ToUtkarsh Ayachit 
PriorityhighSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.4Fixed in Version3.4 
Summary0006783: Cannot convert frustum selection to id selection
DescriptionCreate a Wavelet source and perform a select cells through operation. In the selection inspector, change the selection type from Frustum to either IDs or Global IDs. The selection disappears. The selection should be converted to IDs (which was the behavior in 3.2.1).
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to 0007126closedUtkarsh Ayachit Disable global id selection when global ids are not available. 

-  Notes
(0011760)
Berk Geveci (administrator)
2008-05-08 13:51

Re-enable but add a warning if number of ids in the selection is larger than 10000.
(0011819)
Utkarsh Ayachit (administrator)
2008-05-12 11:37

It's now possible to convert frustum selection to
id/global-id selection. If number of IDs is > 10,000, then a warning is flashed.

------------------------------------
commitid: Jh2cL1CYGUdIOG2t;
------------------------------------
/cvsroot/ParaView3/ParaView3/Servers/ServerManager/vtkSMSelectionHelper.cxx,v <-- Servers/ServerManager/vtkSMSelectionHelper.cxx
new revision: 1.16; previous revision: 1.15
/cvsroot/ParaView3/ParaView3/Qt/Components/pqSelectionInspectorPanel.cxx,v <-- Qt/Components/pqSelectionInspectorPanel.cxx
new revision: 1.27; previous revision: 1.26
(0011877)
Alan Scott (manager)
2008-05-13 19:05

When I select Global ID's, I get lots of grumbling verbage back. Is this expected behavior? Local ParaView, XP.
(0011897)
Ken Moreland (manager)
2008-05-14 10:37

Can you be more specific about the grumbling? I just loaded disk_out_ref, selected the entire thing with a frustum select (either points or cells) and then converted to global ids. The process was silent.
(0011900)
Utkarsh Ayachit (administrator)
2008-05-14 10:45

Alan,

There was a bug in PVGeometryFilter that I fixed (probably yesterday) which was causing some errors on the (process > 0). So you may want to update before trying it out again.
(0012062)
Alan Scott (manager)
2008-05-21 23:10

OK, that fixed the grumbling - too many error messages issue.



Next, I did the following (seems to need to be done exactly as follows):
* Wavelet source.
* Representation: Surface.
* Select cells through.
* Rotate the wavelet with the left mouse button.
* Selection inspector, change selection type from frustum to IDs.
* Rotate the wavelet with the left mouse button.
* Selection inspector, change selection type from IDs to Global IDs. The select goes away - should it?
* Rotate the wavelet with the left mouse button.
* Selection inspector, change selection type from Global IDs to IDs.
* Rotate the cube, and you will find that multiple random cells are now selected. Surely this shouldn't be happening...

Client/Server, 6 pvservers, XP client.
(0012162)
Utkarsh Ayachit (administrator)
2008-05-30 10:32

Conversion to global ids should not be available to wavelet since wavelet doesn't produce gloabl ids. Added a new bug 0007126 for that.
(0012196)
Alan Scott (manager)
2008-06-02 19:12

Fixed. Tested as per my notes below.

- Issue History
Date Modified Username Field Change
2008-04-09 17:47 Ken Moreland New Issue
2008-04-09 17:47 Ken Moreland Status backlog => tabled
2008-04-09 17:47 Ken Moreland Assigned To => Berk Geveci
2008-05-08 13:51 Berk Geveci Note Added: 0011760
2008-05-08 13:51 Berk Geveci Assigned To Berk Geveci => Utkarsh Ayachit
2008-05-12 11:37 Utkarsh Ayachit Status tabled => @80@
2008-05-12 11:37 Utkarsh Ayachit Resolution open => fixed
2008-05-12 11:37 Utkarsh Ayachit Note Added: 0011819
2008-05-13 19:05 Alan Scott Status @80@ => @20@
2008-05-13 19:05 Alan Scott Resolution fixed => reopened
2008-05-13 19:05 Alan Scott Note Added: 0011877
2008-05-14 10:37 Ken Moreland Note Added: 0011897
2008-05-14 10:45 Utkarsh Ayachit Note Added: 0011900
2008-05-16 14:10 Utkarsh Ayachit Status @20@ => @80@
2008-05-16 14:10 Utkarsh Ayachit Resolution reopened => fixed
2008-05-21 23:10 Alan Scott Status @80@ => @20@
2008-05-21 23:10 Alan Scott Resolution fixed => reopened
2008-05-21 23:10 Alan Scott Note Added: 0012062
2008-05-30 10:31 Utkarsh Ayachit Relationship added related to 0007126
2008-05-30 10:32 Utkarsh Ayachit Status @20@ => @80@
2008-05-30 10:32 Utkarsh Ayachit Resolution reopened => fixed
2008-05-30 10:32 Utkarsh Ayachit Note Added: 0012162
2008-06-02 19:12 Alan Scott Status @80@ => closed
2008-06-02 19:12 Alan Scott Note Added: 0012196
2009-05-13 13:58 Utkarsh Ayachit Target Version => 3.4
2009-05-13 13:59 Utkarsh Ayachit Fixed in Version => 3.4
2011-06-16 13:10 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker