View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005894ParaView(No Category)public2007-10-17 14:482009-05-13 13:59
ReporterBerk Geveci 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.4Fixed in Version3.4 
Summary0005894: Save screenshot does not allow saving of all views
DescriptionSave screenshot should support saving of all views together.
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0010025)
Utkarsh Ayachit (administrator)
2007-12-27 11:04

Fixes for BUG 0005895 and BUG 0005894. Added support to save screenshot of all
views. Plot views also correctly save high resimages (except pdf) via screenshot
as well as when saving animation.

/cvsroot/ParaView3/ParaView3/Servers/ServerManager/vtkSMAnimationSceneImageWriter.h,v <-- vtkSMAnimationSceneImageWriter.h
new revision: 1.7; previous revision: 1.6
/cvsroot/ParaView3/ParaView3/Qt/Components/pqAnimationManager.cxx,v <-- pqAnimationManager.cxx
new revision: 1.28; previous revision: 1.27
/cvsroot/ParaView3/ParaView3/Qt/Components/pqAnimationManager.h,v <-- pqAnimationManager.h
new revision: 1.14; previous revision: 1.13
/cvsroot/ParaView3/ParaView3/Qt/Components/pqMainWindowCore.cxx,v <-- pqMainWindowCore.cxx
new revision: 1.243; previous revision: 1.242
/cvsroot/ParaView3/ParaView3/Qt/Components/pqSaveSnapshotDialog.cxx,v <-- pqSaveSnapshotDialog.cxx
new revision: 1.2; previous revision: 1.1
/cvsroot/ParaView3/ParaView3/Qt/Components/pqSaveSnapshotDialog.h,v <-- pqSaveSnapshotDialog.h
new revision: 1.2; previous revision: 1.1
/cvsroot/ParaView3/ParaView3/Qt/Components/pqViewManager.cxx,v <-- pqViewManager.cxx
new revision: 1.50; previous revision: 1.49
/cvsroot/ParaView3/ParaView3/Qt/Components/pqViewManager.h,v <-- pqViewManager.h
new revision: 1.18; previous revision: 1.17
/cvsroot/ParaView3/ParaView3/Qt/Components/Resources/UI/pqSaveSnapshotDialog.ui,v <-- pqSaveSnapshotDialog.ui
new revision: 1.2; previous revision: 1.1
/cvsroot/ParaView3/ParaView3/Qt/Core/pqPlotView.cxx,v <-- pqPlotView.cxx
new revision: 1.19; previous revision: 1.18
(0010066)
Alan Scott (manager)
2008-01-03 18:44

When a user saves screenshot, and turns off the checkbox "Save only selected view", the size does not change. This makes the whole window small. For instance,

Open disk_out_ref.exo.
Split horizontal.
Split both viewports vertically.
Put something in each, creating a set of 2 column by 2 row windows.
Make sure that one of the four windows is highlighted.
File/Save Screenshot.
Resolution will be 612x449 (on my monitor)
Unselect "Save only selected view".
Resolution stays as 612x449, where it should be something like 1200x900.

alan
(0010195)
Utkarsh Ayachit (administrator)
2008-01-18 13:53

When user toggles the "Save only selected view" check box, the sizes are updated.

/cvsroot/ParaView3/ParaView3/Qt/Components/pqMainWindowCore.cxx,v <-- pqMainWindowCore.cxx
new revision: 1.247; previous revision: 1.246
/cvsroot/ParaView3/ParaView3/Qt/Components/pqSaveSnapshotDialog.cxx,v <-- pqSaveSnapshotDialog.cxx
new revision: 1.4; previous revision: 1.3
/cvsroot/ParaView3/ParaView3/Qt/Components/pqSaveSnapshotDialog.h,v <-- pqSaveSnapshotDialog.h
new revision: 1.3; previous revision: 1.2
(0010251)
Alan Scott (manager)
2008-01-23 15:30

I just checked client/server. single window works fine, selected view off failed.

* Open can, accept.
* Horizontal split, turn on eyeball, turn can another direction.
* Save screenshot, save only selected view off. (Size does change correctly)
* Error in vtkImageData.cxx, line 1460. vtkImageData: GetScalarPointer: Pixel (1233,927, 0) not in memory. Current extent= (0,1232, 0, 927, 0, 0)
(0010661)
Utkarsh Ayachit (administrator)
2008-02-27 21:50

I wasn't able to reproduce this. Can you verify if this is fixed?
(0011134)
Ken Moreland (manager)
2008-04-07 18:19

Working for me, too. Looks like it's fixed now.
(0011144)
Alan Scott (manager)
2008-04-07 19:30

Tested client/server.

- Issue History
Date Modified Username Field Change
2007-10-17 14:48 Berk Geveci New Issue
2007-10-17 14:48 Berk Geveci Status backlog => tabled
2007-10-17 14:48 Berk Geveci Assigned To => Utkarsh Ayachit
2007-12-27 11:04 Utkarsh Ayachit Status tabled => @80@
2007-12-27 11:04 Utkarsh Ayachit Resolution open => fixed
2007-12-27 11:04 Utkarsh Ayachit Note Added: 0010025
2008-01-03 18:44 Alan Scott Status @80@ => @20@
2008-01-03 18:44 Alan Scott Resolution fixed => reopened
2008-01-03 18:44 Alan Scott Note Added: 0010066
2008-01-18 13:53 Utkarsh Ayachit Status @20@ => @80@
2008-01-18 13:53 Utkarsh Ayachit Resolution reopened => fixed
2008-01-18 13:53 Utkarsh Ayachit Note Added: 0010195
2008-01-23 15:30 Alan Scott Status @80@ => @20@
2008-01-23 15:30 Alan Scott Resolution fixed => reopened
2008-01-23 15:30 Alan Scott Note Added: 0010251
2008-02-27 21:50 Utkarsh Ayachit Note Added: 0010661
2008-04-07 18:19 Ken Moreland Status @20@ => @80@
2008-04-07 18:19 Ken Moreland Resolution reopened => fixed
2008-04-07 18:19 Ken Moreland Note Added: 0011134
2008-04-07 18:20 Ken Moreland Category Development => 3.4
2008-04-07 19:30 Alan Scott Status @80@ => closed
2008-04-07 19:30 Alan Scott Note Added: 0011144
2009-05-13 13:58 Utkarsh Ayachit Target Version => 3.4
2009-05-13 13:59 Utkarsh Ayachit Fixed in Version => 3.4
2011-06-16 13:10 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker