View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005384ParaView(No Category)public2007-07-23 10:402009-05-13 13:59
ReporterDavid Karelitz 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.4Fixed in Version3.4 
Summary0005384: Selection and ExtractCTHParts
DescriptionSelection does not work on the output of extractCTHparts.

This is with an AMR CTH dataset using the cvs trunk from monday of last week.

I can draw the selection box, but the pink mesh doesn't show up and nothing is shown in the element inspector.

I then tried to cut/slice the dataset. When I select cells on the cut plane, the pink selection shows up, but the wrong cells are selected and nothing is shown in the element inspector.
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0008428)
Berk Geveci (administrator)
2007-08-13 14:54

This will be done in 3.4 when multi-block selection is working.
(0008751)
Berk Geveci (administrator)
2007-08-29 15:13

This is probably a duplicate. Selection of multi-block does not work yet.
(0011508)
Utkarsh Ayachit (administrator)
2008-04-23 12:05

This should work now, selection on composite datasets is now supported.
(0011592)
Alan Scott (manager)
2008-04-29 21:45

Sorry, doesn't work.

XP client/ server (6 pvservers)
Using CTH data from dave, spcta_a.0.
Load all cell array variables. Accept.
Filters/ Extract CTH Parts.
Unselect Material volume fraction - 2, leave everything else as default.
Apply.
Select Cells On, try to rubber band select the object. Cells are selected randomly - on the back of the object.

Select Cells through, and select points all work.
(0011598)
Utkarsh Ayachit (administrator)
2008-04-30 09:40

Ah--the selection was having problems since the data has ghost cells. There was a bug in geometry filter which removed ghost cells before assigning original ids. Consequently original ids were wrong and hence selection mechanism would end up selecting incorrect cells. Fixed that.

/cvsroot/ParaView3/ParaView3/Servers/Filters/vtkPVGeometryFilter.cxx,v <--
Servers/Filters/vtkPVGeometryFilter.cxx
new revision: 1.80; previous revision: 1.79
(0011660)
Alan Scott (manager)
2008-05-01 17:57

Tested client/server.

- Issue History
Date Modified Username Field Change
2007-08-13 14:54 Berk Geveci Note Added: 0008428
2007-08-13 14:54 Berk Geveci Priority high => normal
2007-08-29 15:13 Berk Geveci Note Added: 0008751
2007-08-29 15:13 Berk Geveci Assigned To Berk Geveci => Dave DeMarle
2008-04-09 21:16 Berk Geveci Assigned To Dave DeMarle => Berk Geveci
2008-04-09 21:16 Berk Geveci Category => 3.4
2008-04-23 12:05 Utkarsh Ayachit Status tabled => @80@
2008-04-23 12:05 Utkarsh Ayachit Resolution open => no change required
2008-04-23 12:05 Utkarsh Ayachit Note Added: 0011508
2008-04-29 21:45 Alan Scott Status @80@ => @20@
2008-04-29 21:45 Alan Scott Resolution no change required => reopened
2008-04-29 21:45 Alan Scott Note Added: 0011592
2008-04-30 09:40 Utkarsh Ayachit Status @20@ => @80@
2008-04-30 09:40 Utkarsh Ayachit Resolution reopened => fixed
2008-04-30 09:40 Utkarsh Ayachit Note Added: 0011598
2008-04-30 09:40 Utkarsh Ayachit Assigned To Berk Geveci => Utkarsh Ayachit
2008-04-30 09:40 Utkarsh Ayachit Status @80@ => @20@
2008-04-30 09:40 Utkarsh Ayachit Resolution fixed => reopened
2008-04-30 09:41 Utkarsh Ayachit Status @20@ => @80@
2008-04-30 09:41 Utkarsh Ayachit Resolution reopened => fixed
2008-05-01 17:57 Alan Scott Status @80@ => closed
2008-05-01 17:57 Alan Scott Note Added: 0011660
2009-05-13 13:58 Utkarsh Ayachit Target Version => 3.4
2009-05-13 13:59 Utkarsh Ayachit Fixed in Version => 3.4
2011-06-16 13:10 Zack Galbreath Category => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker