View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004323ParaViewBugpublic2007-01-16 10:582016-08-12 09:57
ReporterDavid Karelitz 
Assigned ToUtkarsh Ayachit 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionmoved 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004323: Programmable Filter Text Editor
DescriptionIs it possible to switch the Text Editor for the Programmable Filter to a monospace font and make tabs insert 4 spaces? Tab auto-indent would be nice, but I'm not sure that can be done.
TagsNo tags attached.
Project
Topic Name
Type
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0006768)
Berk Geveci (administrator)
2007-03-13 15:21

I already changed the tab spacing. Changing the font should be easy.
(0006769)
Berk Geveci (administrator)
2007-03-13 15:21

It would also be nice have an Insert File functionality.
(0007273)
Berk Geveci (administrator)
2007-04-13 09:08

I believe I fixed the font and indentation (no auto-indent though, it is hard to implement)
(0011359)
Clinton Stimpson (developer)
2008-04-15 16:56

Now it has a fixed width font.

/cvsroot/ParaView3/ParaView3/Qt/Components/pqNamedWidgets.cxx,v <-- pqNamedWidgets.cxx
new revision: 1.45; previous revision: 1.44

What's left? Auto-indenting, insert file, or both?
(0012149)
Berk Geveci (administrator)
2008-05-29 13:20

We should at least keep the same indentation as the previous line.
(0015014)
Utkarsh Ayachit (administrator)
2009-02-17 10:49

Preserve the indentation of the previous line.


/cvsroot/ParaView3/ParaView3/Qt/Python/pqPythonShell.cxx,v <-- Qt/Python/pqPythonShell.cxx
new revision: 1.19; previous revision: 1.18
/cvsroot/ParaView3/ParaView3/Qt/Widgets/pqConsoleWidget.cxx,v <-- Qt/Widgets/pqConsoleWidget.cxx
new revision: 1.9; previous revision: 1.8
/cvsroot/ParaView3/ParaView3/Qt/Widgets/pqConsoleWidget.h,v <-- Qt/Widgets/pqConsoleWidget.h
new revision: 1.7; previous revision: 1.6
(0015174)
Alan Scott (manager)
2009-02-18 16:41

As per our conversation, you need to also work on the programmable filter. Since the bug is a bit unclear on specifics, please let me know what you did so I can test it.
(0037507)
Kitware Robot (administrator)
2016-08-12 09:57

Resolving issue as `moved`.

This issue tracker is no longer used. Further discussion of this issue may take place in the current ParaView Issues page linked in the banner at the top of this page.

- Issue History
Date Modified Username Field Change
2008-04-07 16:39 Berk Geveci Assigned To Dave DeMarle => Clinton Stimpson
2008-04-07 16:39 Berk Geveci Category => 3.4
2008-04-15 16:56 Clinton Stimpson Note Added: 0011359
2008-05-29 13:20 Berk Geveci Note Added: 0012149
2008-05-29 13:20 Berk Geveci Category 3.4 => 3.6
2009-02-16 14:46 Ken Moreland Assigned To Clinton Stimpson => Utkarsh Ayachit
2009-02-17 10:49 Utkarsh Ayachit Note Added: 0015014
2009-02-17 10:49 Utkarsh Ayachit Status tabled => @80@
2009-02-17 10:49 Utkarsh Ayachit Resolution open => fixed
2009-02-18 16:41 Alan Scott Note Added: 0015174
2009-02-18 16:41 Alan Scott Status @80@ => @20@
2009-02-18 16:41 Alan Scott Resolution fixed => reopened
2009-05-13 13:46 Utkarsh Ayachit Target Version => 3.6
2009-08-25 18:46 Utkarsh Ayachit Category => Bug
2009-08-25 18:46 Utkarsh Ayachit Target Version 3.6 => 3.8
2016-08-12 09:57 Kitware Robot Note Added: 0037507
2016-08-12 09:57 Kitware Robot Status expired => closed
2016-08-12 09:57 Kitware Robot Resolution reopened => moved


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker