View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013550VTK(No Category)public2012-10-23 16:142012-11-15 16:11
ReporterSagrailo Crni 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0013550: vtkXMLPMultiBlockDataWriter crashing
DescriptionTest program is attached. I'm trying to write two uniform grid data
blocks, from two different MPI processes and using
vtkXMLPMultiBlockDataWriter, but the program is crashing. I'm using VTK
5.10.1 installed from source into /opt/vtk, and I've built the code
through:
  mpicxx -g -I/opt/vtk/include/vtk-5.10 -o foo foo.cpp \
    -L/opt/vtk/lib/vtk-5.10 -lvtkCommon -lvtkFiltering -lvtkIO -lvtkParallel
I'm running the program through:
  LD_LIBRARY_PATH=/opt/vtk/lib/vtk-5.10 mpirun -np 2 foo
TagsNo tags attached.
ProjectTBD
Typecrash
Attached Filescpp file icon foo.cpp [^] (2,224 bytes) 2012-10-23 16:14
cpp file icon foo2.cpp [^] (1,842 bytes) 2012-10-25 15:54
cpp file icon foo3.cpp [^] (2,071 bytes) 2012-10-25 16:59

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0029517)
Sagrailo Crni (reporter)
2012-10-25 15:54

Sorry, I've attached wrong test program when opening the bug. The correct test program is foo2.cpp.
(0029521)
Sagrailo Crni (reporter)
2012-10-25 17:00

OK, I realized employing vtkMPIController was needed. Fixed test program is attached as foo3.cpp, and it works properly now. Closing the report.
(0029522)
Sagrailo Crni (reporter)
2012-10-25 17:01

Not a bug, as mentioned in notes.

- Issue History
Date Modified Username Field Change
2012-10-23 16:14 Sagrailo Crni New Issue
2012-10-23 16:14 Sagrailo Crni File Added: foo.cpp
2012-10-25 15:54 Sagrailo Crni File Added: foo2.cpp
2012-10-25 15:54 Sagrailo Crni Note Added: 0029517
2012-10-25 16:59 Sagrailo Crni File Added: foo3.cpp
2012-10-25 17:00 Sagrailo Crni Note Added: 0029521
2012-10-25 17:01 Sagrailo Crni Note Added: 0029522
2012-10-25 17:01 Sagrailo Crni Status backlog => closed
2012-10-25 17:01 Sagrailo Crni Resolution open => no change required
2012-11-15 16:10 Utkarsh Ayachit Assigned To => Utkarsh Ayachit
2012-11-15 16:10 Utkarsh Ayachit Status closed => backlog
2012-11-15 16:10 Utkarsh Ayachit Resolution no change required => reopened
2012-11-15 16:11 Utkarsh Ayachit Status backlog => todo
2012-11-15 16:11 Utkarsh Ayachit Resolution reopened => fixed
2012-11-15 16:11 Utkarsh Ayachit Status todo => active development
2012-11-15 16:11 Utkarsh Ayachit Status active development => gatekeeper review
2012-11-15 16:11 Utkarsh Ayachit Status gatekeeper review => customer review
2012-11-15 16:11 Utkarsh Ayachit Status customer review => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker