View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013034ParaView(No Category)public2012-03-27 13:112012-10-29 17:04
ReporterGeorge Zagaris 
Assigned ToGeorge Zagaris 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.98.0 
Summary0013034: Merge AMR-Refactoring
DescriptionMerge in AMR-Refactoring branch which consists the following updates:

(1) Use of new AMR hierarchy. Berger-Collela style AMR uses vtkOverlappingAMR and CTH-style AMR uses vtkNonOverlappingAMR data-structures

(2) All CTH filters were updated to use vtkNonOverlappingAMR

(3) Updates in vtkPVGeometry to properly render Berger-Collela style AMR taking into account visibility(blanking)

(4) Expose VTK AMR and particle readers for Flash and Enzo.

(5) Expose VTK AMR filters such as axis-aligned AMR slice filter and uniform grid resample filter.

(6) Bob's new AMR volume rendering representation which employs an indirect volume rendering approach for AMR datasets by resampling an ROI to a uniform grid.
TagsNo tags attached.
ProjectTBD
Topic Name
Typefeature
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0028412)
Utkarsh Ayachit (administrator)
2012-03-30 14:09

reopening due to dashboard issues. resolve after they have been fixed.
(0028439)
Utkarsh Ayachit (administrator)
2012-04-09 17:02

merged into master
(0028811)
Alan Scott (manager)
2012-07-18 20:47

Programming tag. Also, I have tested AMR-CTH, remote server, Linux, Master.

- Issue History
Date Modified Username Field Change
2012-03-27 13:11 George Zagaris New Issue
2012-03-27 13:11 George Zagaris Assigned To => George Zagaris
2012-03-27 13:11 George Zagaris Status backlog => gatekeeper review
2012-03-27 13:11 George Zagaris Resolution open => fixed
2012-03-30 14:09 Utkarsh Ayachit Note Added: 0028412
2012-03-30 14:09 Utkarsh Ayachit Status gatekeeper review => backlog
2012-03-30 14:09 Utkarsh Ayachit Resolution fixed => reopened
2012-04-04 09:19 George Zagaris Status backlog => gatekeeper review
2012-04-04 09:19 George Zagaris Resolution reopened => fixed
2012-04-09 17:02 Utkarsh Ayachit Fixed in Version => git-master
2012-04-09 17:02 Utkarsh Ayachit Status gatekeeper review => customer review
2012-04-09 17:02 Utkarsh Ayachit Note Added: 0028439
2012-07-18 20:47 Alan Scott Note Added: 0028811
2012-07-18 20:47 Alan Scott Status customer review => closed
2012-10-29 17:04 Utkarsh Ayachit Fixed in Version git-master => 3.98.0


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker