View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012005VTK(No Category)public2011-03-23 08:152016-08-12 09:55
ReporterBryn Lloyd 
Assigned ToKitware Robot 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionmoved 
PlatformVisual Studio 2010 / 2008OSWindowsOS Version7 / XP
Product Version 
Target VersionFixed in Version 
Summary0012005: The INSTALL target does not copy the pdb files into any of the target directories (bin or lib). Affects debug installation
DescriptionI have compiled VTK in Debug mode in visual studio. I would like to provide only the libraries and headers to other users. Normally I would use the INSTALL target, however, it does not copy the *.pdb files into either the bin or lib folders. The pdb files are needed by the visual studio debugger.

Is this a bug?
Steps To Reproduce1. Configure VTK to use VS in CMake
2. Compile VTK in DEBUG mode using Visual Studio.
3. Build INSTALL target

In default install directory C:\Programs\VTK there will be folders named "bin" and "lib". These do not contain the pdb files.
TagsNo tags attached.
ProjectTBD
Typeincorrect functionality
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0025880)
David Partyka (developer)
2011-03-23 08:39

Question: Are pdb files portable? I don't think I've encountered this before but it the do work on other machines then we can probably create a VTK_INSTALL macro that also installs the pdb file if built debug.
(0025882)
Bryn Lloyd (reporter)
2011-03-23 09:18

It seems that pdb files can be portable, if they use relative paths.

There was a bug/fix in cmake, which sets the paths to relative iff CMAKE_USE_RELATIVE_PATH is set to ON.

See this bug report:
http://public.kitware.com/Bug/view.php?id=9042 [^]
(0026561)
Stephan Menzel (reporter)
2011-05-20 05:28

Are there any chances this will be changed or fixed in the foreseeable future?
I just need to know so I can decide whether to create some kind of workaround with scripts or something.

Cheers,
Stephan
(0026562)
David Partyka (developer)
2011-05-20 08:10

Unfortunately this is low on our radar. If you are willing to contribute a patch then we would most definately take it under consideration. Though it would make the most sense if CMake had a built in way to handle this.
(0027731)
Bryn Lloyd (reporter)
2011-11-24 09:51

Since the install target is mostly for distributing the dlls/headers I have decided that it is probably mostly not necessary to have the pdb files (which use substantial disk space). If they are needed it is trivial to copy them manually post-build.
(0031283)
Dave DeMarle (administrator)
2013-07-22 20:33

Dave P no longer works on the project. If these old issues still exist in 6.0.0, reopen them and assign to Dave DeMarle
(0032192)
Dave DeMarle (administrator)
2014-01-21 09:45

You can avoid the need for installing .pdb files by replacing /Zi with /Z7 in the CMAKE_CXX_FLAGS_DEBUG and CMAKE_C_FLAGS_DEBUG configuration settings in CMake for VTK.

See: http://markmail.org/thread/jibk3u5hsjs3crix [^]
(0034224)
Serge Lalonde (reporter)
2015-02-18 11:34

This bug still exists in 6.1. I have to constantly remember to copy the PDB files to my install folder manually.
Note that this affects not only the Debug build configuration but also the RelWithDebInfo build configuration.

Finally, I disagree with using the /Z7 flag. This makes the OBJ files much larger, tends to slow down compilation, it's not compatible with incremental compilation and doesn't work very well with debuggers other than Codeview (which is obsolete AFAIC). I'm not even sure if you can mix /Zi and /Z7 in the same EXE.

I believe that this bug should be reopened.
(0034225)
Dave DeMarle (administrator)
2015-02-18 11:50

reopened per request, lets get this nailed down for 6.3.
(0035622)
Edson Tadeu M. Manoel (reporter)
2015-12-30 10:56

+1
(0037227)
Kitware Robot (administrator)
2016-08-12 09:55

Resolving issue as `moved`.

This issue tracker is no longer used. Further discussion of this issue may take place in the current VTK Issues page linked in the banner at the top of this page.

- Issue History
Date Modified Username Field Change
2011-03-23 08:15 Bryn Lloyd New Issue
2011-03-23 08:18 David Partyka Assigned To => David Partyka
2011-03-23 08:18 David Partyka Status backlog => tabled
2011-03-23 08:39 David Partyka Note Added: 0025880
2011-03-23 09:18 Bryn Lloyd Note Added: 0025882
2011-05-20 05:28 Stephan Menzel Note Added: 0026561
2011-05-20 08:10 David Partyka Note Added: 0026562
2011-05-20 08:10 David Partyka Severity trivial => feature
2011-06-16 13:11 Zack Galbreath Category CMake => (No Category)
2011-11-24 09:51 Bryn Lloyd Note Added: 0027731
2013-07-22 20:33 Dave DeMarle Status backlog => expired
2013-07-22 20:33 Dave DeMarle Note Added: 0031283
2014-01-21 09:45 Dave DeMarle Note Added: 0032192
2014-01-21 09:46 Dave DeMarle Project => TBD
2014-01-21 09:46 Dave DeMarle Type => incorrect functionality
2014-01-21 09:46 Dave DeMarle Resolution open => no change required
2015-02-18 11:34 Serge Lalonde Note Added: 0034224
2015-02-18 11:50 Dave DeMarle Assigned To David Partyka =>
2015-02-18 11:50 Dave DeMarle Note Added: 0034225
2015-02-18 11:50 Dave DeMarle Status expired => backlog
2015-02-18 11:50 Dave DeMarle Resolution no change required => reopened
2015-12-30 10:56 Edson Tadeu M. Manoel Note Added: 0035622
2016-08-12 09:55 Kitware Robot Note Added: 0037227
2016-08-12 09:55 Kitware Robot Status backlog => closed
2016-08-12 09:55 Kitware Robot Resolution reopened => moved
2016-08-12 09:55 Kitware Robot Assigned To => Kitware Robot


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker