View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010828ParaViewBugpublic2010-06-14 13:282011-01-13 17:00
ReporterUtkarsh Ayachit 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.8.1Fixed in Version3.8.1 
Summary0010828: Parallel Volume Rendering issues when geometry is preset
DescriptionFollow the steps:
* pvserver as 4 procs (cannot reproduce with num_procs < 4)
* Wavelet (Volume rendering)
* Contour (default)

Result is wrong (user provided image attached). If you apply "Process ID Scalars" to Contour, you can see that although the geometry is partitioned correctly, the process assignment is incorrect and hence the issues.

TagsNo tags attached.
Project
Topic Name
Type
Attached Filespng file icon depth-issue2.png [^] (181,563 bytes) 2010-06-14 13:28


png file icon bug-10828.png [^] (328,377 bytes) 2010-07-21 21:56

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0021003)
Utkarsh Ayachit (administrator)
2010-06-14 13:36
edited on: 2010-07-08 10:15

commit 2a0b102b94e982fa3871f1309489774a54d59d66
Author: Utkarsh Ayachit <utkarsh.ayachit@kitware.com>
Date: Mon Jun 14 13:33:42 2010 -0400

    Fixed BUG 0010828. Incorrect KdTree used for partitioning geometry.
    
    vtkOrderedCompositeDistributor was not passing in the region assigments for the
    cuts to the distributor. This was resulting in D3 using it's own region
    assigments for the cuts which was resulting in geometry ending up on wrong
    processes. Fixed that.


=== VTK Commit ==
commit 5dca988dc39fba6f128d57a4ad906aa5aa63b0d8
Author: Utkarsh Ayachit <utkarsh.ayachit@kitware.com>
Date: Mon Jun 14 13:32:27 2010 -0400

    For BUG 0010828. Added API to set region assignments.
    
    vtkDistributedDataFilter had API to set user-defined cuts, but not the region
    assignments. This was needed to ensure that the cuts were assignmed to processes
    as expected when volume rendering image data. This commit exposes that API.

(0021004)
Utkarsh Ayachit (administrator)
2010-06-14 13:36

Needs to go to 3.8 branch
(0021320)
Utkarsh Ayachit (administrator)
2010-07-08 10:36

moved to release branch
(0021452)
Alan Scott (manager)
2010-07-21 21:08

Looks correct to me. Note I had to run clean to grid to get the wavelet to show up.

Tested 4 remote servers, trunk, linux.
(0021456)
Alan Scott (manager)
2010-07-21 21:55

Reopening. Utkarsh helped me run this properly. The secret is to change remote render threshold to 0.

It still fails. Attached is a screenshot.
(0021534)
Utkarsh Ayachit (administrator)
2010-07-28 16:54

Could not reproduce. Alan can you verify that server-side windows are not overlapping.
(0021568)
Alan Scott (manager)
2010-07-29 23:34

This looks OK on the trunk, as of right now. I did see some stitching, but I think it may be the graphics card (blackrose). I did not see anything that looked like what this bug was written for. 8 processes.

Trunk, Linux, remote server.

- Issue History
Date Modified Username Field Change
2010-06-14 13:28 Utkarsh Ayachit New Issue
2010-06-14 13:28 Utkarsh Ayachit File Added: depth-issue2.png
2010-06-14 13:28 Utkarsh Ayachit Status backlog => tabled
2010-06-14 13:28 Utkarsh Ayachit Assigned To => Utkarsh Ayachit
2010-06-14 13:36 Utkarsh Ayachit Note Added: 0021003
2010-06-14 13:36 Utkarsh Ayachit Status tabled => @80@
2010-06-14 13:36 Utkarsh Ayachit Resolution open => fixed
2010-06-14 13:36 Utkarsh Ayachit Note Added: 0021004
2010-06-15 09:44 Utkarsh Ayachit Target Version 3.8.2 => 3.8.1
2010-07-07 09:55 Utkarsh Ayachit Fixed in Version => Development
2010-07-08 10:15 Utkarsh Ayachit Note Edited: 0021003
2010-07-08 10:17 Utkarsh Ayachit Note Added: 0021313
2010-07-08 10:35 Utkarsh Ayachit Note Deleted: 0021313
2010-07-08 10:36 Utkarsh Ayachit Note Added: 0021320
2010-07-08 10:36 Utkarsh Ayachit Fixed in Version Development => 3.8.1
2010-07-21 21:08 Alan Scott Note Added: 0021452
2010-07-21 21:08 Alan Scott Status @80@ => closed
2010-07-21 21:55 Alan Scott Note Added: 0021456
2010-07-21 21:55 Alan Scott Status closed => @20@
2010-07-21 21:55 Alan Scott Resolution fixed => reopened
2010-07-21 21:56 Alan Scott File Added: bug-10828.png
2010-07-28 16:54 Utkarsh Ayachit Note Added: 0021534
2010-07-28 16:54 Utkarsh Ayachit Status @20@ => @80@
2010-07-28 16:54 Utkarsh Ayachit Resolution reopened => fixed
2010-07-29 23:34 Alan Scott Note Added: 0021568
2010-07-29 23:34 Alan Scott Status @80@ => closed
2011-01-13 17:00 Source_changeset_attached => VTK master a2bd8391
2011-01-13 17:00 Source_changeset_attached => VTK master 020ef709


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker