View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010593ParaViewBugpublic2010-04-22 08:542010-07-08 10:39
Reportertzapuu 
Assigned ToUtkarsh Ayachit 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version3.8.1Fixed in Version3.8.1 
Summary0010593: Big-Endian files
Description The Paraview versions 3.6/3.8 Beta are not able to open anymore files written in Big-Endian order. We produce the files on a sun machine and post process them on a Linux PC.

The file could be opened trouble loss with Paraview version 3.4
TagsNo tags attached.
Project
Topic Name
Type
Attached Filesgz file icon Paraview.tar.gz [^] (65,204 bytes) 2010-05-27 09:12

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0020643)
Utkarsh Ayachit (administrator)
2010-05-07 13:29

I believe the reporter is referring to Ensight reader panel no longer having the endian-ness option. That's because the reader automatically figures out the endian-ness, without having the user to choose it.
(0020664)
tzapuu (reporter)
2010-05-08 10:45
edited on: 2010-05-08 10:48

Hi,

Maybe I did not clarify the issue good enough. Sorry.

The endian detector you mention does very well the detection BUT I suppose it detect the endian writing based on the system - NOT the actual file. And here it comes the problem: If the files are produced on another Operating System/Machine/Cluster than the machine where paraview is running, one CAN NOT open them anymore.

So:
1 my desktop PC is a Linux machine (here i use Paraview)
2 I generate the "Ensight gold" files on a sun/solaris (different endian)
3 When I try to open the files the endianness is wrong taken from the Linux machine even if the files are written in different Endian order.

The files and so are corect as they work as a charm in Paraview 3.4

If more infos are needed please let me know.

Best regards,
Adrian

(0020709)
Ken Moreland (manager)
2010-05-11 11:51

It might be helpful if example files were uploaded/attached to this bug report.
(0020827)
Utkarsh Ayachit (administrator)
2010-05-26 15:05

Please attach a sample dataset.
(0020835)
tzapuu (reporter)
2010-05-27 09:19

Hi all,

As requested a small example has been uploaded.

Best regards,
Adrian
(0020885)
Buddel (reporter)
2010-06-01 13:09

Hey,

I have the same problem. If I try to open the "Ensight Gold" case-files on my Linux/Ubuntu mashine I get the same failure. I generate the files on sun solaris too. If I try to open the file unter Windows 32Bit, I get the same failure.

Here is the output message:
++++++++++++++++++++++++++++++++++++++++++++++
ERROR: In ..\..\..\src\Servers\Filters\vtkEnSightGoldBinaryReader2.cxx, line 150
vtkEnSightGoldBinaryReader2 (0543DB88): Error with subline extraction upon file initialization


ERROR: In ..\..\..\src\Servers\Filters\vtkEnSightReader2.cxx, line 307
vtkEnSightGoldBinaryReader2 (0543DB88): error reading geometry file


ERROR: In ..\..\..\src\VTK\Filtering\vtkExecutive.cxx, line 756
vtkCompositeDataPipeline (0C73C5D8): Algorithm vtkEnSightGoldBinaryReader2(0543DB88) returned failure for request: vtkInformation (05503CE0)
  Debug: Off
  Modified Time: 75761
  Reference Count: 1
  Registered Events: (none)
  Request: REQUEST_DATA
  FROM_OUTPUT_PORT: 0
  FORWARD_DIRECTION: 0
  ALGORITHM_AFTER_FORWARD: 1
++++++++++++++++++++++++++++++++++++++++++++++

In my opinion the problem is the endian-ness "autodetection" which don't get the correct endian-ness of the binary files (with ParaView 3.4 I get errors like this if I choose the wrong endian-ness).

Is there a switch or option to turn off the autodetection of endian-ness?

Regards
(0020962)
Utkarsh Ayachit (administrator)
2010-06-10 09:56

commit 860a8c5225743eb078b99a977ca064f5de4c824e
Author: Utkarsh Ayachit <utkarsh.ayachit@kitware.com>
Date: Thu Jun 10 09:53:17 2010 -0400

    Fixed BUG 0010593 Bug in EnSight byte-ordering auto-detection.
    
    vtkEnSightGoldBinaryReader2::ReadLine() was getting called before the code that
    auto-detected the byte order. There was code in ReadLine() that relied on
    byte-order being set!!! That was the bug (esp. with fortran written files).
    Fixed ReadLine() to handle the case when byte order hasn't been set explicitly.


--------------------------------------------------------------------------------
TODO: Commit should be added to "release" branch.
(0021052)
Alan Scott (manager)
2010-06-16 18:10

Tested using included data, trunk, Windows, local server.
(0021324)
Utkarsh Ayachit (administrator)
2010-07-08 10:39

moved to release

- Issue History
Date Modified Username Field Change
2010-04-22 08:54 tzapuu New Issue
2010-04-22 09:01 Julien Jomier Project @16@ => ParaView
2010-05-07 13:29 Utkarsh Ayachit Note Added: 0020643
2010-05-07 13:29 Utkarsh Ayachit Status backlog => @80@
2010-05-07 13:29 Utkarsh Ayachit Fixed in Version => 3.8
2010-05-07 13:29 Utkarsh Ayachit Resolution open => unable to reproduce
2010-05-07 13:29 Utkarsh Ayachit Assigned To => Utkarsh Ayachit
2010-05-08 10:45 tzapuu Note Added: 0020664
2010-05-08 10:45 tzapuu Status @80@ => @20@
2010-05-08 10:45 tzapuu Resolution unable to reproduce => reopened
2010-05-08 10:48 tzapuu Note Edited: 0020664
2010-05-08 13:30 Utkarsh Ayachit Status @20@ => tabled
2010-05-08 13:30 Utkarsh Ayachit Assigned To Utkarsh Ayachit => Zhanping Liu
2010-05-11 11:51 Ken Moreland Note Added: 0020709
2010-05-26 15:05 Utkarsh Ayachit Assigned To Zhanping Liu =>
2010-05-26 15:05 Utkarsh Ayachit Note Added: 0020827
2010-05-26 15:05 Utkarsh Ayachit Status tabled => @20@
2010-05-27 09:12 tzapuu File Added: Paraview.tar.gz
2010-05-27 09:19 tzapuu Note Added: 0020835
2010-06-01 13:09 Buddel Note Added: 0020885
2010-06-09 16:59 Utkarsh Ayachit Status @20@ => tabled
2010-06-09 16:59 Utkarsh Ayachit Assigned To => Utkarsh Ayachit
2010-06-09 16:59 Utkarsh Ayachit Category => Bug
2010-06-09 16:59 Utkarsh Ayachit Fixed in Version 3.8 =>
2010-06-09 16:59 Utkarsh Ayachit Target Version => 3.8.2
2010-06-10 09:56 Utkarsh Ayachit Note Added: 0020962
2010-06-10 09:56 Utkarsh Ayachit Status tabled => @80@
2010-06-10 09:56 Utkarsh Ayachit Resolution reopened => fixed
2010-06-15 09:44 Utkarsh Ayachit Target Version 3.8.2 => 3.8.1
2010-06-16 18:10 Alan Scott Note Added: 0021052
2010-06-16 18:10 Alan Scott Status @80@ => closed
2010-07-07 09:55 Utkarsh Ayachit Fixed in Version => Development
2010-07-07 17:35 Utkarsh Ayachit Note Added: 0021306
2010-07-08 10:39 Utkarsh Ayachit Note Deleted: 0021306
2010-07-08 10:39 Utkarsh Ayachit Note Added: 0021324
2010-07-08 10:39 Utkarsh Ayachit Fixed in Version Development => 3.8.1


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker